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PracticalMEEG 2019 

Brainstorm group 

   

1. Tuesday am:     From raw to ERP 

10:30-11:00    Introduction to Brainstorm (lecture) 

11:00-11:40    Review the recordings 

• Create new protocol “PracticalMEEG”  

 No, use individual anatomy 

 No, use one channel file per acquisition run (MEG/EEG) 

• Introduction to database explorer (list of protocols, exploration modes…) 

• Right-click on protocol top node > New subject: sub-01 

 

• Switch to functional view   (2nd button above the database explorer) 

• Create link to continuous file:  

 Right-click on sub-01 > Review raw file 

 File format:       MEG/EEG: Elekta-Neuromag (*.fif) 

 Select file:         derivatives/meg_derivatives/sub-01/ses-meg/meg/*.fif 

 Select option:   Event channel > STI101 

• Edit the channel types: 

 Right-click on Neuromag channel file > Edit channel file 

 Change the types:  EEG062>EOG,  EEG063>ECG,  EEG061>Misc,  EEG064>Misc 

 Close and save 

• Review MEG:      Right-click on “Link to raw file” > MEG (all) > Display time series  

 Display in columns + channel selection => Left Temporal 

 Time: Display windows of 5s 

 Amplitude: Buttons and shortcuts, AS 

 Scroll to detect the beginning of the continuous head localization (248s) 

 Online filters 

 Events: List, figure, time bar, display modes (dots or lines) 

• Edit events  

 Select 5+6+7:          Events > Merge groups > Famous 

 Select 13+14+15:   Events > Merge groups > Unfamiliar  

 Select 17+18+19:   Events > Merge groups > Scrambled 

 Delete all the other categories of events 

 Events > Add time offset: Faces,Unfamiliar,Scrambled  34.5ms (delay) 

• Add other views  

 EEG:     Right-click on “Link to raw file” > EEG > Display time series 

 ECG:    Right-click on Link > ECG > Display time series 

 Topography:    Right-click on Link > EEG > 2D Sensor Cap   (or CTRL+T)  

 Layout menu:    Alternate between Tiled and Weighted  (keep  Weighted) 

• Close all + Save modifications 

 



 

2 
 

11:40-12:00   Frequency filters 

• Drag and drop the “Link to raw file” in Process1 

 Explain the Process1 tab + Filter box 

• Run process: “Frequency > Power spectrum density”:     

 [250, 300]s,  win=4s,  MEG,EEG  

 Open the PSD file (double-click)  

 Open topography: EEG > 2D Sensor cap 

 Open topography: MEG (mag) > 2D Sensor cap 

 Open topography: MEG (grad norm) > 2D Sensor cap 

 Explain the noise sources / identify possible bad channels:  

 <3Hz: eyes, 10Hz, 50Hz: power, ~300Hz: HPC, EEG016 bad  

• Run process: “Pre-process > Band-pass filter”:   MEG, EEG  

 Lower cutoff:  0 Hz       (No high-pass filter) 

 Upper cutoff:  40 Hz     (Low-pass filter) 

 Try button “View filter response”  

12:00-12:30   Artifacts detection and cleaning 

• Re-reference the EEG recordings 

 Open the filtered file “Raw | low” > EEG 

 Mark EEG016 as bad 

 Record tab: Artifacts > Re-reference EEG:  AVERAGE  

• Detect artifacts  

 Artifacts > Detect heartbeats > EEG063   (ECG) 

 Artifacts > Detect eye blinks > EEG062     (EOG)  

 Select all the blink events groups, menu Events > Merge groups > blink_bad  

• Artifacts > Remove simultaneous > cardiac / blink_bad / 250ms 

• Correct for heartbeat artifacts 

 Artifacts > SSP: Heartbeats > MEG MAG 

 Artifacts > SSP: Heartbeats > MEG GRAD 

 Display 2D topography for the first spatial components 

 Show the influence of the projector on the sensors Left-Temporal 

 Select the artifact component (high %, good topo, removes the artifact) 

• ICA could work for removing heartbeats and blinks from EEG, but not enough time  

2. Tuesday pm:     Sensor level analysis 

15:00-16:00    Epoching and averaging 

• Right-click on filtered file “Raw | low” > Import in database  

 Use events: Famous + Unfamiliar + Scrambled,      Epoch time: [-500, +1200] ms,    Use SSP 

 Remove DC offset  [-500, 0]ms  

 NO Create separate folder for each event type 

• Review trials:  

 Open the first trial MEG+EEG:  Switch back to butterfly view, ALL sensors 

 Open a 2D topography   (CTRL+T)      -      Enable auto-scale (button [AS]) 

 Navigate between trials with F3 / Shift+F3 

 Trials or channels can be marked as bad independently  

 Raster plots:   Right-click on trials > Display as image > EEG  (EEG065) 
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• Average trials 

 Drag and drop all the trial groups in Process1 

 Run process “Average > Average files”:   By trial group (folder average) 

•  Review average  

 Open all averages: MEG + 2D topography view + EEG 

 Review movie of the activity  (hold right/left/pgup/pgdown keys)  

 Close all and open EEG:    Signals  +  all topography modes 

 Overlay EEG065 for 3 averages with Cluster tab  (NEW IND)  

 Overlay averages with 2DLayout  

 Contact sheet topography with 2DDisc:     0ms,  500ms,  16 images  

 Movies…  

16:00-17:00    Time-frequency analysis 

• Wavelets 

 Select all the Famous trials in Process1 

 Run process Frequency > Time-frequency (Morlet wavelets):  

       EEG,    Log: 1:40:60,   1Hz/3s,   Save average 

 Display time-frequency average:  Smooth + hide edge effects 

 Select TF average in Process1  

 Run process:  Standardize > Baseline normalization > Z-score:  [-200, 0]ms 

 Add process:  Extract > Extract time:  [-200, 900]ms, Overwrite 

• Display time-frequency results 

 Display 2D Layout (maps):  Select a few sensors 

 Change colormap:   Maximum -10/+10,  colormap type 

 Add views:  time series + power spectrum + all the other options 

 

3. Wednesday am:     Creating head and source models 

10:30-11:15    Import anatomy 

• Switch to anatomy view   (1st button above the database explorer)  

• Right-click on sub-01 > Import anatomy folder  

 File format: FreeSurfer  

 Select folder: derivatives/freesurfer-reconall/sub-01/ 

 Number of vertices:   10000       (lower value to make it faster) 

 Introduction to the MRI viewer:  

       Exploring the volume  (click, mouse wheel, sliders) 

       Colormaps,      colorbar,    figure popup menu 

 Compute MNI transformation (sets all the fiducials automatically) 

       You need an internet connection to download the SPM atlas 

       Check the positions of NAS / LPA / RPA 

 Explain the coordinates (MRI, SCS, MNI) 
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• Display the head and brain surfaces  

 3D figure: rotation, zoom 

 Predefined views and keyboard shortcuts 

 Surface tab: smooth, sulci, edges  => smooth 60% 

 Scouts tab:  atlases and scouts    [DEMO ONLY] 

 Subcortical atlas (ASEG)    [DEMO ONLY] 

  

11:15-11:40    Registration MRI-sensors 

• Switch to functional view (2nd button above database explorer) 

• In folder with epochs: Right-click on channel file > MRI registration > MEG: Check 

• Channel file: Digitized head points > Remove points points below nasion 

• Channel file: MRI registration > MEG: Edit > Refine registration using head points 

 Save and close,   Apply to EEG: Yes,   Apply to other datasets: Yes 

• Channel file: MRI registration > EEG: Edit > Project electrodes on surface  

 Save and close 

• Channel file > Display sensors > Vectorview306 coils (ALL)  

 

11:40-12:10    Forward model 

• Switch to the anatomy view  

• Right-click on sub-01 > Generate BEM surfaces > 642 / 482 / 482 / 4mm 

• Switch to functional view 

• In folder with epochs:  Right-click on the channel file > Compute head model 

 MEG:   Overlapping spheres 

 EEG:     OpenMEEG BEM  (default options) 

• Display locally fitted spheres  

 

12:10-12:30     Simulation 

• Process1: Empty list 

• Run process: Simulate > Simulate generic signals:  sub-01,  1000 samples, 1000Hz, sin(2*pi*t) 

• Process1: Select simulated signal 

• Run process: Simulate > Simulate recordings from scouts:    

 Brodmann V1R,   Save full,   SNR1=0.2,  SNR2=0   (not possible without noise covariance) 
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4. Wednesday pm:     Single and distributed sources 

15:00-15:20   Noise covariance:  MEG=empty room recordings, EEG=pre-stim baselines 

• Import noise recordings: 

 Right-click on sub-01 > Review raw file 

 File format:      MEG/EEG: Elekta-Neuromag (*.fif) 

 Select file:        derivatives/meg_derivatives/sub-emptyroom/ses-20090409/meg/*.fif 

 Ignore all the questions and warnings: indeed, there is no subject in the MEG 

• Filter noise recordings: 

 Select it in Process1, run process Filter>Band-pass filter: 0-40Hz 

• Compute noise covariance for MEG: 

 Right-click on sub-emptyroom/Raw|Low > Noise cov > Compute from recordings 

 Right-click on noise covariance > Copy to other folders 

• Compute noise covariance for EEG: 

 Select all epochs Famous+Unfamiliar+Scrambled > Noise cov > Compute from recordings 

 Baseline: [-500,0]ms,   EEG only,   Merge with existing noise covariance  

15:20-16:00   Distributed sources / minimum norm estimation 

• Compute MEG sources: 

 Right-click on head model > Compute sources [2018]:   

 Minimum norm, dSPM, Constrained orientation, MEG GRAD + MEG MAG 

 Explain inverse kernel / links in database 

• Display Famous average: 

 Average Famous:   Display MEG     +    2D topo    +    dSPM sources  

 Make sure that the atlas selected is “User scouts”  (in the Scout tab) 

 Smooth cortex surface at 70%,   show sulci,   bottom+back views 

 Explain amplitude threshold at largest peak:  t=85ms   

 Move to beginning: t=0ms,  Amplitude threshold=10% 

 Review movie of activity:    60ms: V1 L+R,    130ms: OFA R,    165ms: FFA R 

16:00-16:30   Regions of interest 

• Go to t=85ms,   amplitude threshold=80%    (Surface tab)  

• Get a close and accessible view: Right hemisphere, smooth cortex, zoom, rotate  

• Create scout V1 

 Scout tab: [Select point] (big cross in the toolbar), then point on the brain 

 Grow to 20 vertices 

 Rename to  V1     (double-click on the scout in the list) 

 (Demo atlas Brodmann) 

• Review trace:    Absolute values,   then relative values 

• Create other scouts to explore the other sources 

 Decrease the threshold 40%    (Surface tab) 

 Go to 130ms:   Create scout OFA    => Grow to 20 vertices 

 Go to 165ms:   Create scout FFA     => Grow to 20 vertices  (constrained) 

• Review all the traces,     Absolute values / Relative values  |  Overlay: Scouts     

   



 

6 
 

16:30-17:00    LCMV Beamformer 

• Compute data covariance: 

 Select all epochs > Data cov > Compute from recordings 

 Baseline: [-500,0]ms,   Data: [30,300]ms,    All sensors  

• Right-click on head model > Compute sources [2018]:   

 LCMV beamformer, Pseudo NAI, Unconstrained, MEG GRAD + MAG 

• Right-click on head model > Compute sources [2018]:   

 Minimum norm, dSPM, Unconstrained, MEG GRAD + MAG  

• Open both source maps: review in time  

 Unconstrained:  Smoother, nicer figures, more complicated to process  

• Display scouts times series for all ROIs, compare with dSPM  

 

 

 

 

16:30-17:00   Dipole scanning / Volume source models 

• Right-click on channel file > Compute head model 

 MRI volume,  MEG: Overlapping sph, Regular grid,  brain,  5mm  

• Right-click on head model > Compute sources > Dipole modeling 

• Demo: Display dipole maps (not a distributed source model) 

• Select the dipoles map in Process1 

• Run process Sources > Dipole scanning:  [50,300]ms 

• Demo:  Dipole fitting with FieldTrip ft_dipolefitting  (70-100ms, MEG MAG) 

5. Thursday am:     Group-level analysis 

10:30-11:00    Project source maps on MNI template 

• Right-click on Famous average dSPM > Project sources > Default anatomy > cortex_15000V 

 Right-click on subject dSPM > Cortical activations > Display on cortex       (t=85ms) 

 Right-click on subject dSPM > Cortical activations > Display on spheres 

 Right-click on projected dSPM > Cortical activations > Display on cortex 

 Right-click on projected dSPM > Cortical activations > Display on spheres 

  

 

 

   Sub-01 

 

 

 

Default anatomy 

(MNI ICBM152)  
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11:00-11:45    Statistical testing 

• Parametric t-test on sensors 

 In Process2 tab:   FilesA=Famous+Unfamiliar trials,  FilesB=Scrambled 

 Run process:  Test > Parametric test: Independent 

 [0,500]ms,   Student’s t-test (equal variance),   two-tailed test 

 Right-click > MEG (all) > Display time series    +    Press CTRL+T for 2D topographies  

 Right-click > EEG > Display time series             +    Press CTRL+T for 2D topographies 

 In Stat tab, set alpha threshold to 0.01,  FDR correction  

   

  

 

 

 

 

 

• Cluster-based statistics 

 Run process:   Test > FieldTrip: ft_timelockstatistics 

 MEG MAG, [0,300]ms, 1000 randomizations, Independent, two-tailed, cluster, alpha=0.05  

 

 

 

 

 

• During computation: explain interactions with: 

 FieldTrip:      Structure conversions, direct calls  

 MNE-Python:   Create Python objects and call Python function (though Matlab >= 2015b) 

 SPM:                  Export to .nii or .gii files   (online tutorial) 

 EEGLAB:            Functions embedded in the Brainstorm distribution (runica.m) 

• Permutation t-test on sources 

 In Process2: Select “Process sources” on both sides   

 +  Filter to get the dSPM constrained sources   

 Run process:  Test > Permutation test: Independent 

 [140,170]ms, Average selected time window, t-test (equal), two-tailed  

 Right-click figure > Colormap > Absolute values  

11:45-12:30   Scripting 

• Generating Matlab scripts  

• Reports viewer 

• Writing plugins / Sharing code 

6. Thursday pm:     User requests 


