Stylus button not working on fastrak digitizer

Our lab is using a Polhemus fastrak digitizer. We are able to collect coordinates by pointing the stylus at different positions and hitting the 'collect' button on the GUI. However, we are not able to collect any coordinates when we press the button on the stylus.
Here are the troubleshooting steps I have tried:

Are you able to suggest other troubleshooting steps?

Thank you for your time.

Diksha Srishyla

@Marc.Lalancette ?


I would suggest troubleshooting the stylus itself in that case - sounds like a broken button. Polhemus have a (buggy) software you can use to do basic tests and in particular it reports error codes if there's issues with a part. Polhemus PiMgr app If you need to download it, you'll have to contact them for the password. They can also help troubleshoot of course. Note that this app only works with USB connection to the Polhemus, so remember to disconnect USB and reconnect serial and restart the Polhemus, once you're done testing with the app.

Otherwise, you can review the Polhemus configuration (with serial commands or with the app), ensure only serial (not usb) is plugged, and that the stylus/receiver are plugged in the correct order (I think stylus needs to be in plug 1, but please verify).

Here's some additional info from Polhemus support regarding their app:

PiMgr will not connect via RS232 at 9600.

If you can connect via USB then we can do all of these tests that way.

Yes, you can collect points with the stylus from PiMgr.

First put the FasTrak in stylus-point mode:

Make sure the tracker is not in continuous mode.

Then, Selece Device Menu→Sensor Configuration
Select Sensor 1 and Select the Stylus Tab:
Select Point/Track Mode and then click OK.
Notice that PiMgr has entered Point/Track Mode by the
button pushed in on the toolbar.

Push the button on the stylus a few times.. It may take 1-4 pushes to get the points to where you get one point per stylus button push.

Thank you Marc, for this information. I write to let you know that I am still troubleshooting. I will update you when it is complete.

Hello Marc,
The stylus button communicates to Brainstorm now. Polhemus tech support guided me through the following steps, which fixed it:

  • Using the terminal program, connect at 9600.
  • Enable ASCII Output Format ( F command )

    • (PiMgr may be leaving the system in binary output.. It seems unfathomable that Brainstorm can't handle that but..)
  • Reset System to Defaults ( W command )

  • Save Operational Configuration ( Ctl-k command )

  • Then disconnect the terminal program.

  • Power FasTrak OFF then ON again.

  • Then try again with Brainstorm.

Thank you for your guidance with this.

Thanks for sharing the steps. Glad you were able to get it working again.