
Instructors: Takfarinas Medani, Yash Vakilna, Chinmay Chinara, Woojae Jeong

OUTLINE OF TOPICS COVERED IN THIS WORKSHOP

● Morning session: EEG and MEG Analysis
1. Introduction to Brainstorm Interface
2. Import anatomy
3. Review Raw recordings
4. Import events
5. Frequency filters
6. Artifact detection and correction
7. Sensor level

■ Import recordings
■ Review trials
■ Trial averages

8. Forward model (aka Head model)
9. Noise covariance matrix

10. Computing inverse model and source estimation
11. Optional: Atlases and Scouts
12. Optional: Automatic EEG localization and labeling

● Afternoon session: SEEG Analysis
13. Import anatomy
14. Coregister and Normalize images to standard MNI space
15. Contact localization
16. Review Raw recordings
17. SEEG preprocessing
18. Import precomputed Brainstorm protocol
19. Modeling interictal spikes using Min-Norm Imaging
20. Modeling ictal onset with Low Voltage Fast Activity (LVFA) using fingerprint analysis (Sensor Space)
21. Appendix

■ How to run CAT12 segmentation from
■ Remove power line noise
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Brainstorm installation for the workshop:

Please read the following instructions carefully to prepare your laptop for the training:

https://neuroimage.usc.edu/brainstorm/WorkshopGeneralInstall

Workshop datasets:

Once you have successfully installed and tested Brainstorm, proceed to download the data to be used in
the workshop.

For both AM and PM sessions, we will provide you with the raw data as well as the precomputed
Brainstorm protocol. That way, you can either follow this walkthrough and reproduce your results
[recommended], or just load the precomputed results and explore the results and other features [not
covered in this workshop].

● Morning session data:
○ workshopLaxMorning: https://tinyurl.com/2wfwex4s
○ Extract all the folders above to your desktop.
○ This file contains three folders

■ raw: folder with the raw data
■ precomputed: Brainstorm folder with the final results
■ demo: Brainstorm protocol with the EEG 3D scanner

demo

This dataset is collected from a simple median nerve stimulation experiment:

● Right median nerves were percutaneously stimulated using monophasic square-wave impulses
with a duration of 0.3 ms at 2.8 Hz.

● The stimulus intensity was set at the motor threshold to evoke mild twitches of the thumb.
● The stimulus onsets were recorded as low-to-high TTL with a trigger channel labeled as

"Trigger01".
● The total number of stimuli in the dataset was 339.
● The MEG data was recorded with a sampling rate of 2000 Hz and a bandpass filter at 0.16-500

Hz with a Yokogawa 160 axial gradiometer system at Yokogawa Electric Corporation,
Kanazawa, Japan.

● The EEG data was recorded with a NIHON KOHDEN system simultaneously with the MEG.
● Afternoon session data: please check the page 23
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** red highlighted texts are processing steps we will be skipping during this workshop to save time

Morning session: EEG and MEG Analysis

1. Introduction to Brainstorm Interface (Takfarinas)
● CLOSE ALL YOUR APPLICATIONS, INCLUDING WEB BROWSERS
● Start Brainstorm: from MATLAB or using the stand-alone application.

○ Please check here for running Brainstorm for the first time:
https://neuroimage.usc.edu/brainstorm/WorkshopGeneralInstall#Running_Brainstorm_for_the_fi
rst_time
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2. Import Anatomy
Create new protocol

● Select File > New protocol: WorkshopLaxMorning
○ No, use individual anatomy
○ No, use one channel file per acquisition run (MEG/EEG)

● Introduction to database explorer (list of protocols, exploration modes...)

● Switch to anatomy view: (1st button, on top of the database explorer)
● Right-click on protocol top node > New subject: Subject01 (use Defaults)
● Right-click on the created subject > Import anatomy folder (Do not select the

(auto) option)
○ Files of Type CAT12
○ Select the anatomy folder in /Desktop/workshopLaxMorning/raw/
○ For the “Number of vertices” set to 15000
○ You need to have a CAT121 plugin

● Once the MRI viewer opens
○ Explain fiducial points and the coordinates (MRI, SCS, MNI)
○ Set coordinates: , set fiducials, (MRI coords)
○ NAS [125, 230, 64] LPA [48, 141, 44] RPA [215, 140, 59]

● Exploring MRI ( ): double-click or right-click > Display > MRI Viewer
○ Exploring the volume (click, mouse wheel, sliders)
○ Anatomical atlases, colormaps, colorbar, figure popup menu

● Exploring MRI ( ): right-click > Display > 3D orthogonal slices
● Display cortex ( ): double-click or right-click > Display

○ 3D figure: rotation, zoom
○ Predefined views and keyboard shortcuts: left, right, top, etc
○ Surface tab: smooth, sulci, edges
○ Scouts tab: atlases and scouts

● Close all figures ( button at top-right): close all figures and empty the memory.

1 https://neuroimage.usc.edu/brainstorm/Tutorials/SegCAT12#Install_CAT12
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3. Review Raw recordings
● Switch to functional view: (2nd button, on top of the database explorer)
● Create Link to raw file: right-click on Subject01 > Review raw file

○ Files of Type MEG/EEG: Yokogawa/KIT (*.sqd; *.con; *.raw; *.ave; *.mrk)
○ Select the file SEF_000-export.con in the data folder in

/Desktop/workshopLaxMorning/raw/
○ Click on Open

● In the popup for Refining registration, click on No
● The sensor coregistration will show, close it for now
● Change the type of some channels: right-click on the channel file > Edit

channel file:
○ Channel EO1 (208) and EO2 (209): Change the type to EOG
○ Channel EKG+ (214): Change the type to ECG
○ Channel E (231): Change the type to Misc
○ Close the figure and accept to save the modifications

● Check sensor coregistration
○ right-click > MRI registration > EEG:Check

Some electrodes are above or inside the head surface
○ right-click > MRI registration > EEG: Edit

■ Select Project electrodes on the surface
■ Click OK and Yes to save

○ right-click > MRI registration > MEG:Check
○ Close figures

● Review EEG signals: right-click > EEG > Display time series
○ Display in columns ( ), display windows of 10s
○ Amplitude gain: buttons and shortcuts
○ Add a topography and set the window layout to weighted

● Review MEG signals
● Review EOG signals
● Review EEG and EOG signals simultaneously
● Close all figures

4. Import events
● Different ways of Importing events
● Right-click on Link to raw file > TRIGGER > Display time series

○ Display in columns. Notice that Trigger01 contains information of
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the electric stimuli
● In the Record tab, menu File > Read events from channel

○ Event channels = Trigger01
○ Option = TTL: detect peaks of 5V/12V on an analog channel
○ Do NOT check the option Accept zeros as trigger values

● Click Run. Close the figure with the time series to save modifications

5. Frequency filters
● Process section

○ Tabs Process1, Process2
○ File types: recordings, sources, time-freq, and

matrices
● EEG and MEG: Filter power line artifact

○ Close all the figures
○ Drag-and-drop ( ) raw file in Process 1, click [RUN]
○ Add the process: Frequency > Power spectrum density (Welch)

■ Time window = All file, Window length = 5s, Overlap = 50%
■ Units = Physical
■ Sensor types = EEG, MEG

○ PSD Options: Edit… > OK. Click on Run.
● Open the new ( ) PSD file

○ Two PSD groups, from top to bottom: EEG and MEG sensors
○ Peak around 11 Hz: alpha waves from the subject's brain
○ Peaks at 60Hz, 120Hz, 180Hz on EEG and MEG: Power lines

(60Hz+harmonics)
○ Smaller peaks at 35Hz, 65Hz, 70Hz, 183Hz, 197Hz on MEG only:

Unknown source
○ MEG sensor LC11 appears to have a higher level of noise than all

the other MEG sensors.
Select the channel (it becomes red), right-click, and Mark the
selected as bad.
This is often an indication of a bad channel, we can verify this by
reviewing MEG signals.

● Notch filter the raw file: click [RUN],
○ Add the process Pre-process > Notch filter

■ Frequencies to remove (Hz) = 60, 120, 180
■ Sensor types = EEG, MEG
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○ Click Run. Compute the PSD for the notch-filtered raw file, and open
the new PSD file

● EEG and MEG: Bandpass filter. First Clear list for the Process.
○ Drag-and-drop notch-filtered raw file in Process, click [RUN]
○ Add the process Pre-process > Band-pass filter

■ Sensor types = EEG, MEG, Lower cutoff freq = 0.5 Hz, Upper
cutoff freq = 200 Hz

○ Select: Frequency, Power spectrum density (Welch)
○ Add the process: Frequency, Power spectrum density (Welch)
○ PSD Options: Edit… > OK. Run the pipeline.

● EEG: re-reference to Average
○ Open the EEG timeseries for the bandpass filtered raw file (in folder

_notch_band)
● Click on Artifacts > Re-reference EEG and use AVERAGE as EEG

reference channel

● Delete intermediate files that won't be needed anymore:
○ Select folder SEF_000-export_notch
○ Press the Delete key (or right-click > File > Delete)

6. Eye-movement-related artifacts and other artifacts
● Detect eye-movement events

○ Open the time series for EEG and EOG
○ In the Record tab, select Artifacts > Detect eye blinks, and use the

parameters:
■ Channel name = EO2, Time window = All file, Event name =

blink
○ Display MEG signals (along EOG) and see some blink occurrences
○ Merge all the blink event groups in a blinks group

● Detect heartbeat events
○ Open the time series for EEG and ECG
○ In the Record tab, select Artifacts > Detect heartbeats, and use the

parameters:
■ Channel name = EKG+, Time window = All file, Event name = cardiac

● Handle simultaneous events
○ In the Record tab, select Artifacts > Remove simultaneous:

■ Remove events named: cardiac
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■ When too close to events: blinks
■ Minimum delay between events: 250 ms

● Remove blink artifacts from EEG with ICA2

○ Open the time series for EEG
○ In the Record tab, select Artifacts > ICA components, and use the

parameters:
■ Time window = All file, Band-pass filter = [0, 0], Resample = 0, ICA algorithm = Picard,

Number of ICA components = 0
Sort components based on correlation with = EOG, ECG

○ In the Select active projectors window, uncheck all ICA components,
highlight the first eight and plot their time series ( ), and topologies

○ Open ECG and EOG time series and disable auto scaling ( )
in the 3 plots

○ Check Component #1 which is related to the ECG signal and
verify the impact of removing it from the EEG signal

○ Check Component #2 which seem related to the EOG signal and
verify the impact of removing it from the EEG signal

○ Click on Save, close all figures

● Optional: Remove blink artifacts from MEG with SSP
○ Open the time series for MEG
○ In the Record tab, select Artifacts > SSP: Eye blinks, and use the

parameters:
■ Event name = blinks, Sensors = MEG

○ In the Select active projectors window, uncheck all components,
highlight the first two and plot them ( )

○ Open MEG and EOG time series and disable auto scaling ( ) in
the 3 plots

○ Check Component #1 to verify the impact of removing it from the
MEG signal

○ Click on Save, close all figures

7. Sensor level analysis
● Import recordings in the database

○ Right-click on the pre-processed file > Import in database, and use
the parameters:

2 https://neuroimage.usc.edu/brainstorm/Tutorials/Epilepsy#Artifact_cleaning_with_ICA
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■ Time window = 0 - 119.9995 s
■ Do NOT check Split in time blocks
■ Check Use events and select Trigger01 (x340)
■ Epoch time = -50 to 250 ms
■ Check Apply SSP/ICA projectors
■ Check Remove DC offset, select All recordings

○ Answer Yes to this question to discard the last epoch.
○ A new folder named SEF_000-export_notch_band is created (no

more raw indicator)

● Review trials
○ Trials groups ( Trigger01), contain same-name trials (often imported

from with the same event)
○ Trials containing an bad event (with bad in its name) are labeled as

bad ( )
○ Rastre plots: Right-click on trial group > Display as image > EEG

select channel CP5 in the Display Tab

● Average trials
○ Drag and drop all the trial groups in Process1
○ Run process Average > Average files:

■ Group files = Everything, Function = Arithmetic average
● Check different plots for the average somatosensory evoked potential (SEP)

in EEG signals, and the somatosensory evoked fields (SEF) in MEG signals.
Plot both topographies

● Optional: Create a sensor cluster
○ Open the Cluster tab by clicking on the plus sign (+) at the right of Record tab
○ Click on to create a new cluster by indicating the sensor names, use C3, CP5, P3
○ Plot the cluster time series with on the plot button ( )

● Observe Components N20, P25, N33 and P45 visible over left somatosensory cortex in EEG and their
respective fields in MEG

● Close all figures. Do not save the created cluster
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8. Forward model (aka Head model)
● Computing boundary element (BEM) layers

○ Go to the anatomy view
○ Right-click on Subject01 folder > MRI segmentation > Generate BEM

surfaces
■ Select Brainstorm
■ Number of vertices: Scalp = 1082, Outer skull = 642 and Inner

skull = 642
■ Thickness of layers, Skull (mm) 4
■ Note: This number of vertices is selected to avoid long computations during the

workshop. Otherwise, values of 1922 vertices can be used.
○ Right-click on the default cortex (in green) > Force inside skull
○ The fix cortex is now selected as default

● Compute the head model for EEG and MEG
○ Go back to the functional data view
○ Right-click on the channel file ( ) in the SEF_000-export_notch_band

folder > Compute head model
■ Source space = Cortex surface
■ Forward model = MEG: Overlapping spheres and EEG: OpenMEEG BEM
■ Click on OK

● Use default BEM layers and conductivities
● Use default OpenMEEG options

■ The process may take up to 5 min
● Optional: FEM Method with Duneuro

The forward model can also be computed using the FEM method
○ Computation of FEM meshes from BEM surfaces.
○ They can also be computed from MRI volumes
○ The forward model can be computed with the DUNEuro plugin

9. Noise covariance matrix
● Compute noise covariance for EEG and MEG from pre-stimulus baselines

○ Select the trial group, right-click > Noise covariance > Compute from
recordings:

■ Baseline = [-50, 0] ms, Sensors = EEG and MEG
○ Select Block by block

10. Computing inverse models
● Compute inverse model (EEG)
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○ Right-click on the head model ( ) > Compute sources [2018], use these parameters:
■ Select Minimum norm imaging, Select Current density map
■ Select Constrained: Normal to the cortex
■ Sensors = EEG

○ Compute inverse model (MEG)
■ Right-click on the head model ( ) > Compute sources [2018],

use these parameters:
● Select Minimum norm imaging, Select Current

density map
● Select Constrained: Normal to the cortex
● Sensors = MEG

○ Explanation of the inversion kernel ( ) and link ( ) files in the
database

○ Explore the estimated average Avg: Trigger (339) at 20ms
■ Display EEG and MEG time series (butterfly mode)
■ Display the sources derived from EEG and MEG data
■ Set the colormap to local maximum (maximum in that time

slice)
● Right-click on the color bar > Colormap: sources > Maximum Local

■ Set time to 100 ms
■ Set Smooth = 30% and Amplitude threshold to 40% (both in the Surface tab)

○ Explore other times, and the evolution of brain activity

11. Optional: Atlases and Scouts
● Display the sources derived from EEG and MEG data

○ In the Scout tab, use the dropbox to select different Atlases
○ Operations with Atlases and Scouts

● Create Scouts
○ Open the sources (from MEG) for the average, left view
○ Select the User Scouts atlas
○ Create scout S1 (primary somatosensory cortex) on the left hemisphere

■ Go to Time 20 ms, Amplitude threshold 60% Smooth = 30%
■ Scout tab: Click on Select point ( ), then point on activity in the

postcentral gyrus
■ Grow Scout to 20 vertices
■ Rename to S1 (double-click on the scout in the list)
■ Review trace: Absolute values

● Create a second scout S2 (secondary somatosensory cortex) on the left hemisphere
○ Go to Time 50 ms, Amplitude threshold 20% Smooth = 30%
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○ Scout tab: Click on Select point ( ), then point on activity in the bottom part of the post central
gyrus, which is the anatomical location of S2.

● Review S1 and S2 traces together in absolute values. For sources from EEG and MEG

12. Optional: Automatic EEG localization and labeling
● Load precomputed protocol: File > Load protocol > Load from zip file and

browse for:
/Desktop/workshopLaxMorning/demo/Demo3dScanner.zip

● 3DScanner_sub1 subject added.
○ Right-click on sub1_mesh_tex_defaced surface.
○ Choose Digitize (3D scanner)

● Configure EEG cap point collection: File > Edit settings… How many times do you
want to localize these fiducial at start: Set to 1

● Configure EEG Montage: EEG montage… > From default EEG cap > ICBM152 > ANT > ANT
Waveguard 65

● Collect the required number of anatomical fiducials: Click on the 3D figure, click on ( ) on Panel
iEEG or use the shortcut Ctrl+P to activate collection mode (you will see the mouse cursor change to a
crosshair). Click on the desired location on the 3D model and press key 'C' to collect the NAS, LPA
and RPA fiducials in order. Coordinates list are in cm.
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● Collect EEG points:
○ Collect points in the order Fpz, T7, T8, Oz.
○ Press Auto to initiate the automatic detection and labeling .
○ Click Yes on the disclaimer.

● Collect the desired number of head shape points: To automatically choose 150 random points,
click on Random. These can be seen as the green points in the figure and the numbered 001-150 in
the Coordinates list on the GUI.

● Select File > Save in database and exit to ensure the points are saved in the Brainstorm database.

● For a more details please refer to the Brainstorm tutorial:
https://neuroimage.usc.edu/brainstorm/Tutorials/TutDigitize3dScanner
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** red highlighted texts are processing steps we will be skipping during this workshop to save time

Afternoon session: SEEG Analysis

● Afternoon session data:
○ workshopLaxAfternoon_raw: https://tinyurl.com/y58yt9wx
○ workshopLaxAfternoon_precomputed: https://tinyurl.com/3pasznau

● Extract all the folders above to your desktop.
● In this workshop session, we will be working on a SEEG dataset recorded at the Epilepsy Monitoring

Unit at UTHealth Houston. The data is distributed as raw and pre-processed data.
○ raw data is located in the file workshopLaxAfternoon_raw.zip which contains raw SEEG

recordings (in EDF format), T1 MRI, and CT scan (both in NIfTI format). The raw SEEG
recordings correspond to the following:

■ Two files containing seizure onset:
● Seizure onset with Low-voltage-fast-activity
● Seizure with Ictal repetitive spiking

■ One file with interictal spike and
■ One file containing baseline recordings

○ pre-processed data is located in the file workshopLaxAfternoon_precomputed.zip, which
contains a Brainstorm protocol with the raw data already pre-processed.
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13. SEEG Analysis: Import Anatomy (Chinmay)
● New protocol: workshopLaxAfternoon. New subject: Subject_Seeg
● Import T1 pre-implantation: (5 mins)

○ Prerequisites: SPM plugin
○ Right-click on Subject_Seeg > Import MRI
○ Select format: MRI: NIfTI (*.nii, *.nii.gz)
○ Select: /Desktop/workshopLaxAfternoon_raw/T1_2024_std.nii.gz
○ Introduction to the MRI viewer: Click, mouse wheel, color bar, popup
○ MRI Viewer: Click here to compute MNI normalization and select

the maff8 algorithm. This sets default positions for the fiducials Coordinate systems: MRI, SCS,
World, MNI and also does MNI normalization

○ Click Save
● Import post-implant CT: (10 mins)

○ Prerequisites: SPM plugin
○ Right-click on the Subject_Seeg > Import CT
○ Select format: MRI: NIfTI (*.nii, *.nii.gz)
○ Select file:

/Desktop/workshopLaxAfternoon_raw/CTpost_std.nii.gz
(use pre registered: /Desktop/workshopLaxAfternoon_raw/CTpost_reg.nii.gz)

14. SEEG Analysis: Coregister and Normalize images to standard MNI space
○ Select coregister using SPM. Select Yes to reslice volume. Select

SPM for skull stripping.
(Select Ignore and select No for reslice volume as the CT is already
co-registered and resliced)

○ The MRI viewer opens automatically, showing the post-implantation
CT volume as a colored layer on top of the previous volume. Use this
display to validate that the co-registration of the two volumes is
correct (all the parts of the head must align well).

● Generate isoSurface (2 mins)
○ This creates a thresholded mesh from the CT to separate the contacts

from the rest. This aids the user towards localization of the electrodes
and its contacts more accurately.

○ Right click on CTpost_reg > CT segmentation > Generate
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threshold mesh from CT
○ Set the isoValue for thresholding, the estimation is from the mean of white level and max

intensity of the CT. You can leave it as default, select OK.
○ An isosurface is generated showing the contact as blobs overlayed on the 3D MRI slices. The

Thresh slider under Surface options can be used to fine tune and regenerate mesh with
different isoValues.

15. SEEG Analysis: Contact localization
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● Manual contact localization (30 mins)
○ Right click on Subject_Seeg > SEEG/ECOG implantation. Choose MRI+CT+IsoSurf. This

takes you to the functional tab and Subject_Seeg > Implantation > SEEG/ECOG (0) channel
gets created. The MRI Viewer (CT overlayed MRI) and 3D Viz (isoSurface+3D MRI Slices)
load up as well along with the Panel iEEG.

○ On Panel iEEG Click on the + (Add new electrode). This opens
up the Add electrode window. Enter anything under the
Electrode label based on your convention. For now, enter AH and
press OK.

○ Select SEEG, and choose the electrode model (PMT
2102-14-091/2102-12-101) which is a 12 contact electrode.

○ On Panel iEEG, click the ( ) button (shortcut: Ctrl+P) to activate
coordinate selection in 3D and choose the deepest contact from
the isosurface in 3DViz. This should plot a yellow crosshair
marker point on the contact blob and also update the crosshair
in the MRI Viewer.

Note: You can play around with the Thresh slider under Surface
tab to get better visibility of the contacts in 3D as required
○ Click Set tip and the button turns green, indicating that the tip

has been set. This point in 3D is at the centroid of the blob,
which gives a more accurate location of the contact.

○ With coordinate selection active, repeat the steps above and choose a contact closer to the
skull for the skull entry. Now click Set skull entry and the button turns green indicating that the
entry point has been set. The MRI Viewer gets updated with the electrode.
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○ Click on Save in the MRI Viewer. This saves the new channel file and updates the number of
channels in the database explorer. Click Yes for any other Save windows that pop up.

○ Right click on Subject_Seeg and choose SEEG/ECOG implantation in the Functional tab to
get an updated 3D Viz and MRI Viewer with all the electrodes.

○ Repeat these steps for each SEEG electrode except the last step of saving.
○ To save all the further electrodes, click on Contacts > Save Modifications to update the

channel information and also save the changes to the database.
○ For more details please refer to the Brainstorm tutorial:

https://neuroimage.usc.edu/brainstorm/Tutorials/IeegContactLocalization

● Anatomical labeling (5 mins)
○ Switch to the Anatomy view.
○ Right-click on Subject_Seeg > Add MNI parcellation > AAL3.
○ Close all the figures. Switch back to the Functional view.
○ Right-click on the channel file > iEEG atlas labels
○ Create Subject_Seeg.tsv and click OK. Select all the available options: coordinates in

various coordinate systems, volume parcellations, surface parcellations.
○ The output is a table, one row per sensor contact in the channel file, for each sensor: coordinate

location in the parcellation atlas and probability of the label .

○ For more details please refer to the Brainstorm tutorial:
https://neuroimage.usc.edu/brainstorm/Tutorials/Epileptogenicity#Anatomical_labelling
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16. SEEG Analysis: Review Raw recordings (15 mins) (Yash)

○ In the functional view: (2nd button, on top of the database
explorer)

○ Create Link to raw file: right-click on Subject01 > Review raw file
○ Files of Type EEG: EDF/EDF+

■ Select the file Baseline.edf in the data folder
■ Click on Open

○ Review SEEG: Right-click on Link to raw file > SEEG > Display time
series

■ Display in columns: Button in the Record tab > Display
mode > Column

■ Amplitude: Buttons and shortcuts, Display menu
■ Time: Display windows of 15 seconds, Scroll with F3,

Auto-Scale button
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■ Select bad channels + right click > Channels > Mark selected as bad (if needed)
■ Montages: click Display configuration > Montage > Subject01: SEEG >

Subject01 SEEG: (bipolar 2)
■ Select the montage for the dataset

(Average, Referential, Transversal or longitudinal)
■ For the SEEG dataset, select bipolar 2 montage for continuous chain.

■ Filter settings for review are set under the Filter tab in the panel
■ this is only for visualization
■ Select the checkbox to turn ON the high

or low frequency filter.
■ Add annotations:

■ Got to record view > Events > Add
Group > Event A

■ Select 2 peaks and press E
■ Got to record view > Events > Add

Group > Extended
■ Drag across the window
■ Press E
■ Save annotation: File > Save

modifications
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17. SEEG Preprocessing:
Run CAT12 segmentation:

○ Prerequisite: CAT12 plugin
○ Right click on MRI > MRI segmentation > CAT12
○ Display cortex.
○ Close figure, double-click on cortex_15002V (low-resolution pial

surface)
○ 3D figure: Rotation, zoom, predefined views
○ Surface tab: Smooth slider, sulci, edges
○ Scout tab: Parcellations of the surface vertices
○ Volume parcellations: AAL3, Hammers, tissues
○ Adjust transparency, change the atlas, non-linear MNI

transformation
○ Add MNI parcellation: Schaefer2018_100_7net

○ Close all: Big cross ( ) on the top-right, close all the figures and
empty memory.

For more details refer to the Brainstorm tutorial:
https://neuroimage.usc.edu/brainstorm/Tutorials/SegCAT12#Install_CAT12

Remove power line noise:
○ Compute Periodogram

■ Close all the figures
■ Drag-and-drop ( ) raw file in Process 1, click [RUN]
■ Add the process: Frequency, Power spectrum density (Welch)
■ Time window = All file, Window length = _ s, Overlap = 50%
■ Units = Physical
■ Sensor types = SEEG
■ Click on Run

○ Review Periodogram
■ Peaks at 60Hz, 120Hz, 180Hz on EEG and MEG: Power lines (60Hz+harmonics)

○ Process Notch filter
■ Select: Pre-process > Notch filter
■ Frequencies to remove (Hz) = 180, 300, 420, 540, 660, 780, 900Hz
■ Sensor types = SEEG
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Import recordings:
○ Import in database

■ Right-click on the pre-processed file > Import in database, and use the parameters:
● Time window = 0 - 119.9995 s
● Do NOT check Split in time blocks
● Check Use events and select sEEG onset
● Epoch time = -15000 to 15000 ms
● Check Remove DC offset, select All

recordings
■ A new folder named _ is created (no more raw

indicator)
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18. SEEG Analysis: Import precomputed Brainstorm protocol (5 mins)
● Prerequisite: Download from the zip file from url:

https://tinyurl.com/3pasznau
● Open Brainstorm
● Click File > Load Protocol > Load from zip file

● Click on , and point to the downloaded zipped file:
workshopLaxAfternoon_precomputed.zip

● Protocol called workshopLaxAfternoon_precomputed should appear

19. SEEG Analysis: Modeling interictal spikes using
Min-Norm Imaging

● Compute Forward Model (aka Head Model) (10 mins)
○ Computing boundary element (BEM) layers

■ Prerequisite: OpenMEEG plugin
■ Go to the anatomy view
■ Right-click on Subject01 folder > MRI segmentation >

Generate BEM surfaces
● Select Brainstorm
● Number of vertices: Scalp = 1922, Outer skull = 1922
and Inner skull = 1922
● Thickness of layers, Skull (mm)= 4
● DON’T CLICK [OK]

■ Double-click on mid_15002V to make it as the default cortex (in
green). If already green, no need to double-click.

○ Compute the head model for SEEG
■ Go back to the functional data view, navigate to the interictal_spike

folder and expand it

■ Right-click on the Nihon Kohden channel file ( )> Compute head
model

● Source space = Cortex surface, Forward model = SEEG:
OpenMEEG BEM, click OK

● Use default BEM layers and conductivities.
● Use default OpenMEEG options.

Page | 23

https://tinyurl.com/3pasznau


● DON’T CLICK [OK]
■ Copy the head model files to the other folders

● Right-click on the head-model file ( OpenMEEG BEM | mid 15k)> Copy to
other folders

○ View Leadfield vectors
■ Right-click on head-model file ( ) > View SEEG leadfield vectors
■ Select reference=MC2, click OK
■ Make sure scouts are unselected

● Go to the Scout tab, and make sure ALL and SEL are unselected
● Go back to the Surface tab

■ Select Transparency = 90, and Press Shift+Up arrow till the arrows are visible
■ Press E to show the electrode
■ Press Up/down to change the Reference electrode, right/left to change the Target

■ Press to close all figures

● Compute Noise Covariance Matrix (for SEEG) (15 mins)
○ Explain Process section

■ Tabs Process1, Process2

■ File types: recordings, sources, time-freq, and
matrices

○ Switch to Baseline folder

○ Compute Link to raw file | copy ( ) for sEEG from Baseline recording
■ Select the trial group, right-click > Noise covariance > Compute from recordings:

● Baseline = [0, 301] s
● Select Block by block
● DON’T CLICK [OK]

● Copy the Noise Covariance ( )across other folder
○ Right-click noise covariance file > Copy to other

folders
● Compute Inverse Model (5 mins)

○ Switch to the interictal_spike folder,

○ Right-click on the head model ( ) > Compute sources, use these
parameters:
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■ Click on Show Details
■ Select Minimum norm imaging, Select Measure: sLORETA
■ Select Constrained: Normal to Cortex
■ Select Noise covariance regularization: Diagonal noise covariance
■ Sensors = SEEG
■ DON’T CLICK [OK]

○ Explanation of the inversion kernel ( ) and link ( ) files in the
database

● Display sensor time series (5 mins)
○ Display time series

■ Right-click on Recording ( Spike (#1) …)> SEEG> Display time series
■ On the right side of the figure,
Select ( ) > Montage > Subject01: SPS >Subject01: SPS

(bipolar 2)
■ Select the first peak of SPS10-SPS11 (Time 0.041s)

○ Display 2D Layout of the spike

■ Right-click on Recording ( )> SEEG> 2D Layout

■ Click on the corner and select [-500, 500]

● View Inverse Modeling results (10 mins)
○ Display on Cortex

■ Right-click on link ( sLORETA …) > Cortical activations >
Display on cortex

■ Show sensors:
● Ctrl+L – SEEG contacts, Ctrl+E – for sensors

■ Show colormap Bar: Right Click on Colorbar > Colormap: Sources
> Permanent menu

● Select Maximum: Custom [0, 2]
● Contrast: -18, Brightness: 99
● Switch to Surface tab, Select Amplitude: 56%

○ Display on 3D MRI Viewer

■ Right Click on link ( ) > Cortical activations > Display on MRI
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(3D)
■ Right Click and drag to select Axial, Coronal, and Sagittal slices
■ Press M to go to voxel with Maximum Intensity

○ Display on MRI viewer

■ Right Click on link ( ) > Cortical activations > Display on MRI
(MRI Viewer)

■ Right Click on Colorbar > Electrodes > SEEG contacts
■ Show colormap Bar: Right Click on Colorbar > Colormap : Sources

> Permanent menu
■ Explain Radiological and Neurological view
■ Explain MIP function and MIP anatomical

● Atlases and Scouts (5 mins)
○ Display sources on the Cortical surface

■ Right-click on link ( ) > Cortical activations > Display on cortex
■ In the Scout tab, use the dropbox to select different Atlases
■ Display Desikan-Killiany and Destrieux
■ Subdivided Desikan-Killiany

● Atlas > Subdivide atlas> Area > Area of the sub-regions
(cm2): 5

● DON’T CLICK [OK]
■ Press to close all figures

20. SEEG Analysis: Modeling ictal onset with Low Voltage Fast Activity (LVFA)
using fingerprint analysis (Sensor Space) (Yash
Vakilna)

● Compute Bipolar Montage (5 mins)
○ Navigate and expand LVFA_and_wave folder

○ Press to close all figures

○ Drag-and-drop ( ) recording file in Process 1, click [RUN]
○ Add the process: Standardize>Apply Montage

■ Montage name: Subject01: SEEG (bipolar 2)[tmp]
■ Select Create new folders
■ DON’T CLICK [RUN]

○ A new folder with bipolar_2 suffix will appear
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● Compute Time-Frequency decomposition (5 mins)
○ Navigate and expand LVFA_and_wave_bipolar_2 folder
○ Delete any previous recordings in the Process 1 tab below
○ Drag-and-drop ( ) recording file in Process 1, click [RUN]
○ Add the process: Frequency>Time-Frequency (Morlet wavelets)

■ Sensor type: SEEG
■ Select Spectral flattening: Multiply output power values

by frequency
■ Click Edit …

● Frequency definition: Log (start:N:stop), 1:25:100
● Central Frequency: 1 Hz, Time resolution (FWHM): 6s
● Click [OK]
● DON’T CLICK [RUN]

● View Time-frequency maps (10 mins)
○ Expand ( sEEG onset …) recording file,

right-click on Power ( ), and select All
channels

○ Click on Smooth display, Log(Power)
○ Click on SPS8-SPS9
○ Right-click on Colorbar>Colormap:

Timefreq >Permanent menu
○ Set Turn-off [Absolute Value](if on),

Maximum: Local, Contrast: 49,
Brightness: -65

○ Demonstrate Left-click and Drag on colorbar
to select appropriate Brightness and
Contrast

○ Right-click on the colored time-frequency plot > Power Spectrum, Time Series
○ Click to close all figures
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