
Instructors: Takfarinas Medani, Yash Vakilna, Chinmay Chinara
Once you have successfully installed and tested Brainstorm, proceed to download the data to be used in
the workshop.

● Download the raw data:
○ https://box.bic.mni.mcgill.ca/s/vJWC1ak9CW1M6YU

● Unzip the downloaded raw data on your desktop: it will create a new folder named
workshopLAX_raw

OUTLINE OF TOPICS COVERED IN THIS WORKSHOP

1. Introduction to Brainstorm Interface
2. EEG and MEG Analysis

a. Import anatomy
b. Review Raw recordings
c. Import events
d. Frequency filters
e. Artifact detection and correction
f. Sensor level analysis

i. Import recordings
ii. Review trials
iii. Trial averages

g. Source estimation
i. Forward model (aka Head model)
ii. Noise covariance matrix
iii. Computing inverse models
iv. Atlases and Scouts

3. SEEG Analysis
a. Import anatomy
b. Coregister and Normalize images to standard MNI space
c. SEEG contact localization
d. Review Raw recordings
e. Modeling interictal spikes using Min-Norm Imaging
f. Modeling ictal onset with Low Voltage Fast Activity (LVFA) using fingerprint analysis (Sensor

Space)
g. Appendix: How to run CAT12 segmentation from Brainstorm
h. Appendix: Remove power line noise

Preparing your dataset to be imported to Brainstorm
● MRI DICOM files have to be converted to NIfTI format.
● EEG data can be imported to Brainstorm in native format or EDF file conversions.
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1. Introduction to Brainstorm Interface
● CLOSE ALL YOUR APPLICATIONS, INCLUDING WEB BROWSERS
● Start Brainstorm: from Matlab or using the stand-alone application.

** red highlighted texts are processing steps we will be skipping during this workshop to save
time

2. EEG and MEG Analysis: Import Anatomy
● Select File > New protocol: WorkshopLAX
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○ No, use individual anatomy
○ No, use one channel file per acquisition run (MEG/EEG)

● Introduction to database explorer (list of protocols, exploration modes...)

● Switch to anatomy view: (1st button, on top of the database explorer)
● Right-click on protocol top node > New subject: Subject01 (use Defaults)
● Right-click on the created subject > Import anatomy folder (Do not select the

(auto) option)
○ Files of Type CAT12
○ Select the anatomy folder in Desktop/workshop_lax/
○ For Number of vertices set 15000

● Once the MRI viewer opens
○ Explain fiducial points and the coordinates (MRI, SCS, MNI)
○ Set coordinates: , set fiducials:

(MRI coords) NAS [125, 230, 64] LPA [48, 141, 44] RPA [215, 140, 59]
● Exploring MRI ( ): double-click or right-click > Display > MRI Viewer

○ Exploring the volume (click, mouse wheel, sliders)
○ Anatomical atlases, colormaps, colorbar, figure popup menu

● Exploring MRI ( ): right-click > Display > 3D orthogonal slices
● Display cortex ( ): double-click or right-click > Display

○ 3D figure: rotation, zoom
○ Predefined views and keyboard shortcuts: left, right, top, etc
○ Surface tab: smooth, sulci, edges
○ Scouts tab: atlases and scouts

● Close all figures ( button at top-right): close all figures and empty the memory

3. EEG and MEG Analysis: Review Raw recordings
● Switch to functional view: (2nd button, on top of the database explorer)
● Create Link to raw file: right-click on Subject01 >

○ Files of Type MEG/EEG: Yokogawa/KIT (*.sqd; *.con; *.raw; *.ave; *.mrk)
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○ Select the file SEF_000-export.con in the data folder in Desktop/workshop_lax/
○ Click on Open

● In the popup for Refining registration, click on No
● The sensor coregistration will show, close it for now

● Change the type of some channels, right-click on the channel file > Edit channel
file:

○ Channel EO1 (208) and EO2 (209): Change the type to EOG
○ Channel EKG+ (214): Change the type to ECG
○ Channel E (231): Change the type to Misc
○ Close the figure and accept to save the modifications

● Check sensor coregistration
○ right-click > MRI registration > EEG:Check

Some electrodes are above or inside the head surface
○ right-click > MRI registration > EEG: Edit

■ Select Project electrodes on surface
■ Click OK and save

○ right-click > MRI registration > MEG:Check
○ Close figures

● Review EEG signals: right-click > EEG > Display time series
○ Display in columns ( ), display windows of 10s
○ Amplitude gain: buttons and shortcuts
○ Add a topography and set the window layout to weighted

● Review MEG signals
● Review EOG signals
● Review EEG and EOG signals simultaneously
● Close all figures

4. EEG and MEG Analysis: Import events
● Different ways of Importing events
● Right-click on Link to raw file > TRIGGER > Display time series

○ Display in columns. Notice that Trigger01 contains the information
of the electric stimuli

● In the Record tab, menu File > Read events from channel
○ Event channel = Trigger01
○ Option = TTL: detect peaks of 5V/12V on an analog channel
○ Do NOT check the option Accept zeros as trigger values

● Close the figure with the timeseries to save modifications
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5. EEG and MEG Analysis: Frequency filters
● Process section

○ Tabs Process1, Process2
○ File types: recordings, sources, time-freq, and matrices

● EEG and MEG: Filter power line artifact
○ Close all the figures
○ Drag-and-drop ( ) raw file in Process 1, click [RUN]
○ Add the process: Frequency, Power spectrum density (Welch)

■ Time window = All file, Window length = 5s, Overlap = 50%
■ Units = Physical
■ Sensor types = EEG, MEG

○ Click on Run
● Open the new ( ) PSD file

○ Two PSD groups, from top to bottom: EEG and MEG sensors
○ Peak around 11 Hz: alpha waves from the subject's brain
○ Peaks at 60Hz, 120Hz, 180Hz on EEG and MEG: Power lines

(60Hz+harmonics)
○ Smaller peaks at 35Hz, 65Hz, 70Hz, 183Hz, 197Hz on MEG only:

Unknown source
○ MEG sensor LC11 appears to have a higher level of noise than all

the other MEG sensors.
Select the channel (it becomes red), right-click and Mark selected as
bad
This is often an indication of a bad channel, we can verify this by
reviewing MEG signals

● Notch filter the raw file: Select: Pre-process > Notch filter
■ Frequencies to remove (Hz) = 60, 120, 180 Hz
■ Sensor types = EEG, MEG

○ Compute the PSD for the notch-filtered raw file, and open the new
PSD file

● EEG and MEG: Bandpass filter
○ Drag-and-drop notch-filtered raw file in Process , click [RUN]
○ Add the process Pre-process > Band-pass filter

■ Sensor types = EEG, MEG, Lower cutoff freq = 0.5 Hz, Upper
cutoff freq = 200 Hz

■ Click View filter response to see the filter properties
○ Select: Frequency, Power spectrum density (Welch)
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○ Add the process: Frequency, Power spectrum density (Welch)
○ Run the pipeline

● EEG: re-reference to Average
○ Open the EEG timeseries for the bandpass filtered raw file (in folder _notch_band)

● Click on Artifacts > Re-reference EEG and use AVERAGE as EEG reference channel

● Delete intermediate files that won't be needed anymore:
○ Select folder SEF_000-export_notch
○ Press the Delete key (or right-click > File > Delete)

6. EEG and MEG Analysis: Eye-movement related artifacts and
other artifacts

● Detect eye-movement events
○ Open the time series for EEG and EOG
○ In the Record tab, select Artifacts > Detect eye blinks, and use the

parameters:
■ Channel name = EO2, Time window = All file, Event name =

blink
○ Display MEG signals (along EOG) and see some blink occurrences
○ Merge all the blink event groups in a blinks group

● Detect heartbeat events
○ Open the time series for EEG and ECG
○ In the Record tab, select Artifacts > Detect heartbeats, and use the

parameters:
■ Channel name = EKG+, Time window = All file, Event name

= cardiac
● Handle simultaneous events

○ In the Record tab, select Artifacts > Remove simultaneous:
■ Remove events named: cardiac
■ When too close to events: blinks
■ Minimum delay between events: 250 ms

● Remove blink artifacts from EEG with ICA
○ Open the time series for EEG
○ In the Record tab, select Artifacts > ICA components, and use the

parameters:
■ Time window = All file, Band-pass filter = [0, 0], Resample =

0ICA algorithm = Picard, Number of ICA components = 0
Sort components based on correlation with = EOG, ECG
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○ In the Select active projectors window, uncheck all ICA components, highlight the first eight and
plot their time series ( ), and topologies

○ Open EEG and EOG time series and disable auto scaling ( ) in the 3
plots

○ Check Component #1 which is related to the ECG signal and verify the
impact
of removing it from the EEG signal

○ Check Component #2 which seem related to the EOG signal and verify the impact of removing
it from the EEG signal

○ Click on Save, close all figures

● Remove blink artifacts from MEG with SSP
○ Open the time series for MEG
○ In the Record tab, select Artifacts > SSP: Eye blinks, and use the

parameters:
■ Event name = blinks, Sensors = MEG

○ In the Select active projectors window, uncheck all components,
highlight the first two and plot them ( )

○ Open MEG (all) and EOG time series and disable auto scaling ( )
in the 3 plots

○ Check Component #1 to verify the impact of removing it from the
MEG signal

○ Click on Save, close all figures

7. EEG and MEG Analysis: Import recordings
● Import in database

○ Right-click on the pre-processed file > Import in database, and use
the parameters:

■ Time window = 0 - 119.9995 s
■ Do NOT check Split in time blocks
■ Check Use events and select Trigger01 (x340)
■ Epoch time = -50 to 250 ms
■ Check Apply SSP/ICA projectors
■ Check Remove DC offset, select All recordings

○ Answer Yes to this question to discard the last epoch.
○ A new folder named SEF_000-export_notch_band is created (no more raw indicator)

● Review trials
○ Trials groups ( ), contain same-name trials (often imported from with

the same event)
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○ Trials containing an bad event (with bad in its name) are labeled as bad ( )
○ Rastre plots: Right-click on trial group > Display as image > EEG select channel CP5 in the

Display Tab

● Average trials
○ Drag and drop all the trial groups in Process1
○ Run process Average > Average files:

■ Group files = Everything, Function = Arithmetic average
● Check different plots for the average somatosensory evoked potential (SEP)

in EEG signals, and the somatosensory evoked fields (SEF) in MEG signals.
Plot both topographies

● Create a sensor cluster
○ Open the Cluster tab by clicking on the plus sign (+) at the right of

Record tab
○ Click on to create a new cluster by indicating the sensor names,

use C3, CP5 and P3
○ Plot the cluster time series with on the plot button ( )

● Observe Components N20, P25, N33 and P45 visible over left somatosensory cortex in EEG and their
respective fields in MEG

● Close all figures. Do not save the created cluster
●

8. EEG and MEG Analysis:
Forward model (aka Head model)

● Computing boundary element (BEM) layers
○ Go to the anatomy view
○ Right-click on Subject01 folder > MRI segmentation > Generate BEM

surfaces
■ Select Brainstorm
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■ Number of vertices: Scalp = 1082, Outer skull = 642 and Inner skull = 642
■ Thickness of layers, Skull (mm) 4
■ Note: This number of vertices is selected to avoid long computations during the

workshop. Otherwise, values of 1922 vertices can be used.
○ Right-click on the default cortex (in green) > Force inside skull
○ The fix cortex is now selected as default

● Compute the head model for EEG and MEG
○ Go back to the functional data view
○ Right-click on the channel file ( ) in the imported data folder >

Compute head model
■ Source space = Cortex surface
■ Forward model = MEG: Overlapping spheres and EEG: OpenMEEG BEM
■ Click on OK

● Use default BEM layers and conductivities
● Use default OpenMEEG options

■ The process may take up to 5 min
● Demo: the forward model can be computed also using the FEM method

○ Computation of FEM meshes from BEM surfaces. They can be
computed from volumes

● Forward model can be computed with the DUNEuro plugin

9. EEG and MEG Analysis: Noise covariance matrix
● Compute noise covariance for EEG and MEG from pre-stimulus baselines

○ Select the trial group, right-click > Noise covariance > Compute from
recordings:

■ Baseline = [-50, 0] ms, Sensors = EEG and MEG
○ Select Block by block

10. EEG and MEG Analysis: Computing inverse models
● Compute inverse model (EEG)

○ Right-click on the head model ( ) > Compute sources, use these
parameters:

■ Select Minimum norm imaging, Select Current density map
■ Select Constrained: Normal to the cortex
■ Sensors = EEG

○ Compute inverse model (MEG)
■ Right-click on the head model ( ) > Compute sources, use

these parameters:
● Select Minimum norm imaging, Select Current density map
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● Select Constrained: Normal to the cortex
● Sensors = MEG

○ Explanation on the inversion kernel ( ) and link ( ) files in the
database

○ Explore the estimated average Avg: Trigger (339) at 20ms
■ Display EEG and MEG time series (butterfly mode)
■ Display the sources derived from EEG and from MEG data
■ Set the colormap to local maximum (maximum in that time

slice)
● Right-click on the colorbar > Colormap: sources > Maximum Local

■ Set time to 100 ms
■ Set Smooth = 30% and Amplitude threshold to 40% (both in Surface tab)

○ Explore other times, and the evolution of the brain activity

11. EEG and MEG Analysis: Atlases and Scouts
● Display the sources derived from EEG and MEG data

○ In the Scout tab, use the dropbox to select different Atlases
○ Operations with Atlases and Scouts

● Create Scouts
○ Open the sources (from MEG) for the average, left view
○ Select the User Scouts atlas
○ Create scout S1 (primary somatosensory cortex) on the left

hemisphere
■ Go to Time 20 ms, Amplitude threshold 60% Smooth = 30%
■ Scout tab: Click on Select point ( ), then point on activity in the

post central gyrus
■ Grow Scout to 20 vertices
■ Rename to S1 (double-click on the scout in the list)
■ Review trace: Absolute values

● Create a second scout S2 (secondary somatosensory cortex) on the left
hemisphere

○ Go to Time 50 ms, Amplitude threshold 20% Smooth = 30%
○ Scout tab: Click on Select point ( ), then point on activity in the bottom part of the post central

gyrus, which is the anatomical location of S2.
● Review S1 and S2 traces together in absolute values. For sources from EEG and MEG
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12. SEEG Analysis: Import Anatomy
● Import T1 pre-implantation: (5 mins)

○ Right-click on Subject01 > Import MRI
○ Select format: MRI: NifTI
○ Select file: T1_2024_std.nii.gz
○ Introduction to the MRI viewer: Click, mouse wheel, color bar, popup
○ In the MRI Viewer, click on Compute MNI normalization and select
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the maff8 algorithm. This sets default positions for the fiducials Coordinate systems: MRI, SCS,
World, MNI and also does MNI normalization

○ Click Save
● Import post-implant CT: (10 mins)

○ Prerequisites: BrainSuite , ct2mrireg plugin
○ Right-click on the Subject01 > Import CT
○ Select format: MRI: Nifti
○ Select file: CTpost_std.nii.gz (pre registered CTpost_reg.nii.gz)

13. SEEG Analysis: Coregister and Normalize images to
standard MNI space

○ Select coregister using CT2MRI and select Yes both to reslice volume
and clean CT volume. (Select Ignore and select No for reslice volume as the CT is already
co-registered.)

○ The MRI viewer opens automatically, showing the post-implantation
CT volume as a colored layer on top of the previous volume. Use this
display to validate that the co-registration of the two volumes is
correct (all the parts of the head must align well).

● Generate isoSurface (2 mins)
○ This creates a thresholded mesh from the CT to separate the

contacts from the rest. This aids the user towards localization of the
electrodes and its contacts more accurately.

○ Right click on CTpost_reg> CT segmentation > Generate threshold
mesh from CT

○ Set the isoValue for thresholding, the estimation is from the mean of
white level and max intensity of the CT. You can leave it as default,
select OK

○ An isosurface is generated showing the contact as blobs overlayed on
the 3D MRI slices. The Thresh slider under Surface options can be
used to fine tune and regenerate mesh with different isoValues.

14. SEEG Analysis: Contact localization
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● Manual contact labeling (30 mins)
○ Right click on CTpost_reg and choose SEEG/ECOG implantation. This takes you to the

functional tab and Subject01 > Implantation > SEEG/ECOG (0) channel gets created. The
MRI Viewer (CT overlayed MRI) and 3D Viz (isoSurface+3D MRI Slices) load up as well
along with the Panel iEEG.

○ Click the + icon from the list of panel tabs and choose Add: Coordinates. This adds the Panel
Coordinates which will be used to select points from the 3D Viz.

○ On Panel iEEG Click on the + (Add new electrode). This opens
up the Add electrode window. Enter anything under the Electrode
label based on your convention. For this e.g., enter AH and press
OK.

○ Select SEEG, and choose the electrode model (PMT
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2102-14-091/2102-14-101 which is a 14 contact electrode.
○ Switch to the Coordinates panel, click Select and choose the deepest contact from the

isosurface in 3Dviz. This should plot a yellow crosshair marker point on the contact blob and
also update the crosshair in the MRI Viewer.

Note: You can play around with the Thresh slider under Surface tab to get better visibility of the
contacts as required
○ Switch back to the iEEG panel and click Set tip and the button

turns green, indicating that the tip has been set. This point in 3D is
at the centroid of the blob, which gives a more accurate location of
the contact.

○ Go back to the Coordinates tab and repeat the steps above for
the skull entry

○ Now click Set skull entry and the button turns green indicating
that the entry point has been set. The MRI Viewer gets updated
with the electrode.

○ Click on Save in the MRI Viewer. This saves the new channel file and updates the number of
channels in the database explorer. Click Yes for any other Save windows that pop up.

○ Double-click the Implantation > SEEG/ECOG channel in the Functional tab to get an updated
3D Viz and MRI Viewer with all the electrodes.

○ Repeat these steps for each SEEG electrode except the last step of saving.
○ For saving all the further electrodes, click on Contacts > Save Modifications to update the
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channel information and that saves the changes to the database.

● Anatomical labeling (5 mins)
○ Switch to the anatomy view.
○ Right-click on Subject01 > Add MNI parcellation > AAL3. Repeat with parcellation:

Hammers83, Hammers95.
○ Close all the figures. Switch back to the Functional view.
○ Right-click on the channel file > iEEG atlas labels
○ Create Subject01.tsv and click OK. Select all the available options: coordinates in various

coordinate systems, volume parcellations, surface parcellations.
○ The output is a table, one row per sensor contact in the channel file, for each sensor: coordinate

location in the parcellation atlas and probability of the label .

15. SEEG Analysis: Review Raw recordings (15 mins)
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○ In the functional view: (2nd button, on top of the database explorer)
○ Create Link to raw file: right-click on Subject01 > Review raw file
○ Files of Type EEG: EDF/EDF+

■ Select the file Baseline.edf in the data folder
■ Click on Open

○ Review SEEG: Right-click on Link to raw file > SEEG > Display
time series

■ Display in columns: Button in the Record tab > Display
mode > Column

■ Amplitude: Buttons and shortcuts, Display menu
■ Time: Display windows of 15 seconds, Scroll with

F3, Auto-Scale button
■ Select bad channels + right click > Channels > Mark

selected as bad (if needed)
■ Montages: click Display configuration > Montage >

Subject01: SEEG > Subject01 SEEG: (bipolar 2)
■ Select the montage for the dataset

(Average, Referential, Transversal or longitudinal)
■ For the SEEG dataset, select bipolar 2 montage

for continuous chain.

■ Filter settings for review are set under the Filter tab in the
panel

■ this is only for visualization
■ Select the checkbox to turn ON the high

or low frequency filter.
■ Add annotations:

■ Got to record view > Events > Add
Group > Event A

■ Select 2 peaks and press E
■ Got to record view > Events > Add

Group > Extended
■ Drag across the window
■ Press E
■ Save annotation: File > Save modifications
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16. SEEG Analysis: Import precomputed Brainstorm
protocol (5 mins)

● Prerequisite: Download from the zip file from url:
https://box.bic.mni.mcgill.ca/s/Yqjt3sciljtHMqF

● Open Brainstorm
● Click File > Load Protocol > Load from zip file

● Click on , and point to the downloaded zipped file:
WorkshopUTAH_precomputed.zip

● Protocol called WorkshopUTAH_precomputed should appear

17. SEEG Analysis: Modeling interictal spikes using Min-Norm Imaging (Yash
Vakilna)

● Compute Forward Model (aka Head Model) (10 mins)
○ Computing boundary element (BEM) layers

■ Prerequisite: OpenMEEG plugin
■ Go to the anatomy view
■ Right-click on Subject01 folder > MRI segmentation >

Generate BEM surfaces
● Select Brainstorm
● Number of vertices: Scalp = 1922, Outer skull = 1922
and Inner skull = 1922
● Thickness of layers, Skull (mm)= 4
● DON’T CLICK [OK]

■ Double-click on mid_15002V to make it as the default cortex (in
green). If already green, no need to double-click.

○ Compute the head model for SEEG
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■ Go back to the functional data view, navigate to the interictal_spike
folder and expand it

■ Right-click on the Nihon Kohden channel file ( )> Compute head
model

● Source space = Cortex surface, Forward model = SEEG:
OpenMEEG BEM, click OK

● Use default BEM layers and conductivities.
● Use default OpenMEEG options.
● DON’T CLICK [OK]

■ Copy the head model files to the other folders
● Right-click on the head-model file ( OpenMEEG BEM | mid

15k)> Copy to other folders
○ View Leadfield vectors

■ Right-click on head-model file ( ) > View SEEG leadfield vectors
■ Select reference=MC2, click OK
■ Make sure scouts are unselected

● Go to the Scout tab, and make sure ALL and SEL are
unselected

● Go back to the Surface tab
■ Select Transparency = 90, and Press Shift+Up arrow till the arrows are visible
■ Press E to show the electrode
■ Press Up/down to change the Reference electrode, right/left to change the Target

■ Press to close all figures

● Compute Noise Covariance Matrix (for SEEG) (15 mins)
○ Explain Process section

■ Tabs Process1, Process2

■ File types: recordings, sources, time-freq, and
matrices

○ Switch to Baseline folder

○ Compute Link to raw file | copy ( ) for sEEG from Baseline recording
■ Select the trial group, right-click > Noise covariance > Compute from recordings:

● Baseline = [0, 301] s
● Select Block by block
● DON’T CLICK [OK]
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● Copy the Noise Covariance ( )across other folder
○ Right-click noise covariance file > Copy to other folders

● Compute Inverse Model (5 mins)
○ Switch to the interictal_spike folder,

○ Right-click on the head model ( ) > Compute sources, use these parameters:

■ Click on Show Details
■ Select Minimum norm imaging, Select Measure: sLORETA
■ Select Constrained: Normal to Cortex
■ Select Noise covariance regularization: Diagonal noise

covariance
■ Sensors = SEEG
■ DON’T CLICK [OK]

○ Explanation of the inversion kernel ( ) and link ( ) files in the database

● Display sensor time series (5 mins)
○ Display time series

■ Right-click on Recording ( Spike (#1) …)> SEEG>
Display time series

■ On the right side of the figure,
Select ( ) > Montage > Subject01: SPS >Subject01: SPS

(bipolar 2)
■ Select the first peak of SPS10-SPS11 (Time 0.041s)

○ Display 2D Layout of the spike

■ Right-click on Recording ( )> SEEG> 2D Layout

■ Click on the corner and select [-500, 500]
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● View Inverse Modeling results (10 mins)
○ Display on Cortex

■ Right-click on link ( sLORETA …) > Cortical activations >
Display on cortex

■ Show sensors:
● Ctrl+L – SEEG contacts, Ctrl+E – for sensors

■ Show colormap Bar: Right Click on Colorbar > Colormap: Sources > Permanent
menu

● Select Maximum: Custom [0, 2]
● Contrast: -18, Brightness: 99
● Switch to Surface tab, Select Amplitude: 56%

○ Display on 3D MRI Viewer

■ Right Click on link ( ) > Cortical activations > Display on MRI
(3D)

■ Right Click and drag to select Axial, Coronal, and Sagittal slices
■ Press M to go to voxel with Maximum Intensity

○ Display on MRI viewer

■ Right Click on link ( ) > Cortical activations > Display on MRI
(MRI Viewer)

■ Right Click on Colorbar > Electrodes > SEEG contacts
■ Show colormap Bar: Right Click on Colorbar > Colormap : Sources

> Permanent menu
■ Explain Radiological and Neurological view
■ Explain MIP function and MIP anatomical

● Atlases and Scouts (5 mins)
○ Display sources on the Cortical surface

■ Right-click on link ( ) > Cortical activations > Display on cortex
■ In the Scout tab, use the dropbox to select different Atlases
■ Display Desikan-Killiany and Destrieux
■ Subdivided Desikan-Killiany

● Atlas > Subdivide atlas> Area > Area of the sub-regions
(cm2): 5

● DON’T CLICK [OK]
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■ Press to close all figures
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18. SEEG Analysis: Modeling ictal onset with Low Voltage Fast Activity (LVFA)
using fingerprint analysis (Sensor Space) (Yash
Vakilna)

● Compute Bipolar Montage (5 mins)
○ Navigate and expand LVFA_and_wave folder

○ Press to close all figures

○ Drag-and-drop ( ) recording file in Process 1, click [RUN]
○ Add the process: Standardize>Apply Montage

■ Montage name: Subject01: SEEG (bipolar 2)[tmp]
■ Select Create new folders
■ DON’T CLICK [RUN]

○ A new folder with bipolar_2 suffix will appear

● Compute Time-Frequency decomposition (5 mins)
○ Navigate and expand LVFA_and_wave_bipolar_2 folder
○ Delete any previous recordings in the Process 1 tab below
○ Drag-and-drop ( ) recording file in Process 1, click [RUN]
○ Add the process: Frequency>Time-Frequency (Morlet wavelets)

■ Sensor type: SEEG
■ Select Spectral flattening: Multiply output power values

by frequency
■ Click Edit …

● Frequency definition: Log (start:N:stop), 1:25:100
● Central Frequency: 1 Hz, Time resolution (FWHM): 6s
● Click [OK]
● DON’T CLICK [RUN]

● View Time-frequency maps (10 mins)
○ Expand ( sEEG onset …) recording file, right-click on Power ( ),

and select All channels
○ Click on Smooth display, Log(Power)
○ Click on SPS8-SPS9
○ Right-click on Colorbar>Colormap: Timefreq >Permanent menu
○ Set Turn-off [Absolute Value](if on),

Maximum: Local, Contrast: 49,
Brightness: -65

○ Demonstrate Left-click and Drag on colorbar
to select appropriate Brightness and
Contrast
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○ Right-click on the colored time-frequency plot > Power Spectrum, Time Series
○ Click to close all figures
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SEEG Analysis: Appendix
● How to run CAT12 segmentation from Brainstorm

○ Display cortex:
○ Close figure, double-click on cortex_15002V (low-resolution pial

surface)
○ 3D figure: Rotation, zoom, predefined views
○ Surface tab: Smooth slider, sulci, edges
○ Scout tab: Parcellations of the surface vertices
○ Volume parcellations: AAL3, Hammers, tissues
○ Adjust transparency, change the atlas, non-linear MNI

transformation
○ Add MNI parcellation: Schaefer2018_100_7net

Import T1 post-implantation:
○ Right-click on Subject01 > Import MRI
○ Select file: /xxx/xxxx/xxxxx.nii.gz
○ Apply transformation: YES
○ How to register: IGNORE (volumes are already co-registered with

SPM)
○ Reslice the volume: YES (so we can overlay them)
○ Surface tab: Adjust threshold with slider Data options: Amplitude

Close all: Big cross on the top-right, close all the figures and empty
memory.

● Remove power line noise.
○ Compute Periodogram

■ Close all the figures

■ Drag-and-drop ( ) raw file in Process 1, click [RUN]
■ Add the process: Frequency, Power spectrum density (Welch)
■ Time window = All file, Window length = _ s, Overlap = 50%
■ Units = Physical
■ Sensor types = SEEG
■ Click on Run

○ Review Periodogram
■ Peaks at 60Hz, 120Hz, 180Hz on EEG and MEG: Power lines (60Hz+harmonics)
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○ Process Notch filter
■ Select: Pre-process > Notch filter
■ Frequencies to remove (Hz) = 180, 300, 420, 540, 660, 780, 900Hz
■ Sensor types = SEEG

● Import recordings
○ Import in database

■ Right-click on the pre-processed file > Import in database, and use the parameters:
● Time window = 0 - 119.9995 s
● Do NOT check Split in time blocks
● Check Use events and select sEEG onset
● Epoch time = -15000 to 15000 ms
● Check Remove DC offset, select All

recordings
■ A new folder named _ is created (no more raw indicator)
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