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1.​ Brainstorm download and installation 
Brainstorm is available in an open-source MATLAB application (MATLAB license required) and a standalone 
Java executable (free). Both are available for download in the same package. Please follow the instructions 
on this page for a complete installation and configuration: 
https://neuroimage.usc.edu/brainstorm/Installation 
To make sure that Brainstorm is correctly installed on your computer and ready for the workshop 

●​ Start Brainstorm:  
○​ With Matlab: Go to the installation folder and type brainstorm in the Matlab terminal 
○​ Without Matlab:  

○​ Windows: Double-click on brainstorm3.bat 
○​ MacOS: Double-click on brainstorm3.command and wait for instructions 
○​ Linux: From a terminal, run: 

cd brainstorm3/bin/R2023a/​
./brainstorm3.command 

             Check this link for more details: https://neuroimage.usc.edu/brainstorm/Installation#Start_Brainstorm 

●​ ⚠ Having any issues with Brainstorm: Please follow the instructions on this page: ​ ​  

​ https://neuroimage.usc.edu/brainstorm/WorkshopGeneralInstall​
 

2.​ Workshop datasets 
Once you have successfully installed and tested Brainstorm, proceed to download the data to be used in the 
workshop. We will provide you with the raw data and the precomputed Brainstorm protocol. You can either 
follow this walkthrough to reproduce these steps from the raw data or directly load the precomputed results 
to explore the outcomes and additional features. Since some sections involve lengthy computations, we 
recommend loading the precomputed protocol during the workshop. You can consistently reproduce these 
computations on your own afterward.  
📜 If not yet done, please download the data from the following links: 

o​ WorkshopSEEG_raw: https://tinyurl.com/5a8yeca4    
o​ WorkshopSEEG_precomputed: https://tinyurl.com/5n6hb6yz   

Extract all the folders above to your desktop. 
In this workshop session, we will work on a SEEG dataset recorded at 
the Epilepsy Monitoring Unit at UTHealth Houston. The data is 
distributed as raw and pre-processed Brainstorm protocol data. 

o​ raw data is located in the file WorkshopSEEG_raw.zip, which 
contains raw anatomical scans and SEEG recordings (in EDF 
format).  

■​ The anatomical scans include 
●​ One raw pre-implantation T1 and T2 MRI 
●​ One raw post-implantation CT scan 
●​ One post-implantation CT coregistered to the T1, resliced and skull-stripped using SPM 
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●​ One raw diffusion-weighted MRI (DWI) 
■​ The raw SEEG recordings correspond to the following: 

●​ One file containing baseline recordings: “Baseline.edf” 
●​ Two files containing seizure onset: 

a.​ Seizure onset with Low-voltage-fast-activity: “LVFA_and_wave.edf” 
b.​ Seizure with Ictal repetitive spiking: “ictal_repetitive_spike.edf” 

●​ One file with interictal spike:  “interictal_spike.edf” 
o​ WorkshopSEEG_precomputed.zip contains the pre-processed Brainstorm protocol folder.​

 

3.​ Introduction to Brainstorm Interface 
●​ CLOSE ALL YOUR APPLICATIONS, INCLUDING WEB BROWSERS 

●​ Start Brainstorm: from MATLAB or using the stand-alone application.  

○​ Please refer to this page for more instructions: 
https://neuroimage.usc.edu/brainstorm/Installation#Start_Brainstorm 
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    ⚠  red highlighted texts are processing steps we will be skipping during this workshop to save time​
 

4.​ Create a new Brainstorm Protocol & Subject 
●​ Select > File > New protocol > WorkshopSEEG 

■​ No, use individual anatomy 

■​ No, use one channel file per acquisition run (MEG/EEG)  

●​ Create a New subject 

Switch to anatomy view:   (1st button, on top of the database explorer)  

○​ Right-click on protocol top node > New subject: Subject01 (use 
Defaults) 

          You can find more details here: ​ 
         https://neuroimage.usc.edu/brainstorm/Tutorials/CreateProtocol 
 

5.​ Import & explore anatomical data in Brainstorm  
●​ Import T1 pre-implantation:  (5 mins) 

○​ Right-click on Subject01 > Import MRI 

○​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 

○​ Select file: /Desktop/WorkshopSEEG_raw/pre_T1_raw.nii.gz 

○​ Introduction to the MRI viewer: Click, mouse wheel, color bar, popup 
○​ In the MRI Viewer, click on Compute MNI normalization and 

select the maff8 algorithm. This sets default positions for the 
fiducials Coordinate systems: MRI, SCS, World, and MNI, and also 
does MNI normalization. This process can take ~1 minute. 

○​ Click Save & Close 

●​ Import and coregistration of  T2 pre-implantation:  (3 mins) 

○​ Right-click on Subject01 > Import MRI 

○​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 

○​ Select file: /Desktop/WorkshopSEEG_raw/pre_T2_FLAIR_raw.nii.gz 
●​ Brainstorm asks about registering the new T2 with the reference T1 image: 

○​ MRI Orientation: Yes 
○​ Select the option: SPM [if not installed, Brainstorm will download and install SPM as plugin] 
○​ Reslice the volume: Yes 

●​ This process will take a few minutes, just be patient, and once 
completed, close the MRI viewer. A new node will appear in the database.​
It contains the T2 MRI co-registered with the T1 MRI.  
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●​ Explore the Brainstorm MRI viewer (5min) 

○​ Explain fiducial points and the coordinates (MRI, SCS, MNI) 

○​ Set coordinates:       , set fiducials, (MRI coords)  
●​ Exploring MRI (     ): double-click or right-click > Display > MRI Viewer 

○​ Exploring the volume (click, mouse wheel, sliders) 
○​ Anatomical atlases, colormaps, colorbar, figure popup menu 

●​ Exploring MRI (      ): right-click > Display > 3D orthogonal slices 
●​ Close all figures (  button at top-right): close all figures and empty the memory. 

 

●​ Generate head surface from the MRI:  (5 mins)   
       Once the fiducials are set, Brainstorm can generate a head surface from the MRI.  

○​ Right-click on pre_T1_raw> MRI Segmentation > Generate head 
surface​
keep the default values and click OK, this process will take ~2min.  

○​ A new node will appear on the database , double click to open this 
new surface or right-click > Display 

■​ 3D figure: rotation, zoom, Surface Tab 
■​ Predefined views and keyboard shortcuts: left, 

right, top, etc 
■​ Surface tab: smooth, sulci, edges 
■​ Scouts tab: atlases and scouts 

 
 

●​ Optional: Defacing MRI data (anonymize  the subject):  (3 mins)   

●​ Right-click on pre_T1_raw > Deface Volume 

●​ A new MRI volume will appear in the database 
This option uses SPM and cuts the volume below a predefined  
 cutting plan.  

📜If you have the BrainSuite package installed, Brainstorm offer a second option for the defacing. It uses a 
predefined mask to anonymize the MRI without cutting off the front of the head (see the figure on the right). 
This can be performed from the Process tab >  Import > Import Anatomy > Deface MRI Volumes.  
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6.​ MRI Segmentation in Brainstorm  
📜 In this section, we explain how to perform MRI segmentation and the supported tools/files within Brainstorm.​

⚠ DO NOT RUN THE MRI SEGMENTATION  DURING THE WORKSHOP ⚠​
We will provide you with the precomputed files in the following sections. 

For estimating the brain sources of the Ephys signals, the subject's anatomy must include at least three files: a 
T1-weighted MRI volume, the envelope of the cortex, and the surface of the head. Brainstorm cannot extract 
the cortex envelope from the MRI, you have to run this operation with an external program of your choice. The 
results of the MRI segmentation obtained with the following programs can be automatically imported: 
FreeSurfer, BrainSuite, BainVISA, CAT12, and CIVET. ​
​
CAT12 is the only application fully interfaced with Brainstorm, and available for download as a Brainstorm 
plugin. FreeSurfer is widely regarded as a reference in this domain; therefore, we will provide a precomputed 
FreeSurfer segmentation for this workshop. However, we can also use CAT for this analysis. 

●​ MRI Segmentation with CAT12 

CAT12 is an SPM12 toolbox, it can efficiently replace FreeSurfer to generate the cortical surface from any T1 
MRI. It runs on any OS in about 1 hour. It is fully interfaced with Brainstorm as a plugin. CAT12 requires the 
prior installation of SPM12. Both are MATLAB-based programs that can be installed automatically as 
Brainstorm plugins.​
​
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●​ How to Run CAT from Brainstorm: 

●​ Switch to the anatomy side of the database explorer . 
●​ Right-click on the MRI > MRI segmentation > CAT12.  
●​ Two options can be selected interactively: ​

The number of final vertices in the cortex surfaces and the computation of additional volume 
parcellations. 

●​ How to Import CAT Segmentation to Brainstorm: 
       If you need to import an existing CAT segmentation, follow the following procedure. 

●​ Right-click on the Subject > Import anatomy folder. 
●​ A figure is automatically shown at the end of the process to visually check that the low-resolution cortex and 

head surfaces were generated correctly and imported. You can find more details in this tutorial: 
https://neuroimage.usc.edu/brainstorm/Tutorials/SegCAT12​
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7.​ SEEG contact localization 
📜In this section, we will just demonstrate only one electrode. The full localizations 
will be explored later in the precomputed protocol, where all the 267 contacts of the 
16 electrodes are marked by a clinician using Brainstorm.  

●​ Import post-implant CT and coregister to pre-implant MRI: (10 mins) 
o​ Prerequisites: SPM plugin [already installed] 
o​ Right-click on the Subject01 > Import CT 
o​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 
o​ Select file: Desktop/WorkshopSEEG_raw/post_CT_coreg.nii.gz  
o​ Select Ignore and choose No for reslice volume and Skip for skull 

stripping as the provided CT is already pre-processed with these steps) 

o​ The MRI viewer opens automatically, showing the post-implant CT 
volume as a colored layer on top of the previous volume. Use this display 
to validate that the co-registration of the two volumes is correct (all the 
parts of the head must align well).  

o​ Surface tab > Data options >  Amplitude, set the slider to 0% to see the 
whole overlay. 

●​ Generate isoSurface (2 mins) 

o​ This creates a thresholded mesh from the CT to separate the contacts 
from the rest. This aids the user in the localization of the electrodes and 
their contacts more accurately. 

o​ Right-click on post_CT_coreg > CT segmentation > Generate threshold 
mesh from CT 

o​ Set the isoValue for thresholding; the estimation is based on the mean 
white level and max intensity of the CT. Set the value to 2050 Hounsfield 
Unit (HU). Select OK. 

o​ An isosurface is generated, showing the contact as blobs are overlayed on 
the 3D MRI slices. Surface tab > Thresh slider can be used to fine-tune 
and regenerate mesh with different isoValues till you get a clear view of 
the contacts with minimal artifacts. 
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●​ Overview of the Panel iEEG 

 

●​ Manual contact labeling (10 mins) 
o​ Right-click on Subject01 > SEEG/ECOG implantation. Choose MRI+CT+IsoSurf. This takes you to the 

functional tab and Subject01 > Implantation  > SEEG/ECOG (0) channel gets created.  The MRI Viewer  
(CT overlayed  MRI) and 3D Viz (isoSurface+3D  MRI Slices)  load up as well, along with the Panel iEEG. 

o​ On Panel iEEG, Click on the + (Add new electrode). This opens up the 
Add electrode window. Under the Electrode label, enter AH and press 
OK (you can use any name based on your convention).  

o​ Select SEEG, and choose the electrode model (PMT 
2102-12-091/2102-14-101), which is a 12 contact electrode. 

o​ On Panel iEEG, click the ( ) button (shortcut: Ctrl+P) to activate 
coordinate selection in 3D and choose the deepest contact from the 
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isosurface in 3DViz. This should plot a yellow crosshair marker point on the contact blob and also 
update the crosshair in the MRI Viewer. 

📜 You can play around with the Thresh slider under the Surface tab to get better visibility of the contacts 
in 3D with minimal artifacts. 

o​ Click Set tip and the button turns green, indicating that the tip has been set. This point in 3D is at the 

centroid of the blob, which gives a more accurate location of the contact.  

o​ With coordinate selection active, repeat the steps above and choose a contact closer to the skull for 
the skull entry. Now click Set skull entry, and the button turns green, indicating that the entry point 
has been set. The MRI Viewer gets updated with the electrode. 

o​ Click on Save in the MRI Viewer. This saves the new channel file and updates the number of channels 
in the database explorer. Click Yes for any other Save windows that 
pop up.  

o​ Right-click on Subject01 and choose SEEG/ECOG implantation in 
the Functional tab to get an updated 3D Viz and MRI Viewer with all 
the electrodes. 

o​ Repeat these steps for each SEEG electrode except the last step of 
saving.  

o​ To save all the further electrodes, click on Contacts > Save 
Modifications to update the channel information and also save the changes to the database. 

o​ For more details, please refer to the Brainstorm tutorial:​
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https://neuroimage.usc.edu/brainstorm/Tutorials/IeegContactLocalization  

●​ Anatomical labeling (5 mins) 

o​ Switch to the Anatomy view. 

o​ Right-click on Subject01 > Add MNI parcellation > AAL3.  

o​ Close all the figures. Switch back to the Functional view.  

o​ Right-click on the channel file > iEEG atlas labels 

o​ Create Subject01.tsv and click OK.  Select all the default options on all the steps: coordinates in 
various coordinate systems, volume parcellations, and surface parcellations. 

o​ The output is a table, one row per sensor contact in the channel file, for each sensor: coordinate 
location in the parcellation atlas and probability of the label. 

o​ For more details, please refer to the Brainstorm tutorial:​
https://neuroimage.usc.edu/brainstorm/Tutorials/Epileptogenicity#Anatomical_labelling 

  
 

           Optional: Automatic SEEG contact localization and labeling (Brainstorm+GARDEL) 

Brainstorm also provides access to tools for automatic sEEG contact localization. However, this software 
version is not yet available for public use. For more details, you can refer to the following resources: 

●​ Abstract: https://www.researchgate.net/publication/386140762 
●​ Demo video: https://www.youtube.com/watch?v=ixyH4DqNU6E 
●​ Tutorial: https://neuroimage.usc.edu/brainstorm/Tutorials/IeegContactLocalization 
●​ GitHub: https://github.com/brainstorm-tools/brainstorm3​

 
​

​ The version is expected to be released next month. 
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8.​ Review RAW recordings 
●​ Overview and exploring the functional tab interface [Record and Filter] 

 
●​ The raw SEEG recordings correspond to the following: 

o​ One file containing baseline recordings: “Baseline.edf” 
■​ 300s “Normal” brain activity [marked by epileptologist] 

o​ Two files containing seizure onset: 
■​ Seizure onset with Low-voltage-fast-activity: 

“LVFA_and_wave.edf” [30 seconds of data] 
■​ Seizure with Ictal repetitive spiking: 

“ictal_repetitive_spike.edf”  [30 seconds of data] 
o​ One file with interictal spike:   

■​ “interictal_spike.edf” [10 seconds of data around a marked spike] 
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●​ In the functional view:  (2nd button, on top of the database explorer)  

○​ Create Link to raw file: right-click on Subject01 > Review raw file 
○​ Files of Type EEG: EDF/EDF+ 

■​ Select the file WorkshopSEEG_raw/Baseline.edf    
■​ Click on Open 

●​ Review SEEG: Right-click on the Link to raw file > SEEG > Display time series 

○​ Display in columns: Button  in the Record tab ​
> Display mode > Column 

■​ Amplitude: Buttons and shortcuts, Display menu 
■​ Time: Display windows of 15 seconds, Scroll with  

■​Next Page: F3 /Previous Page: Shift+F3 
■​Use (Auto-Scale) button to scale amplitude while changing the page 

■​ Shortcuts: See the tooltips in the time panel for important keyboard shortcuts 
📜 visit this link for complete keyboard shortcuts:     
    https://neuroimage.usc.edu/brainstorm/Tutorials/ReviewRaw#Mouse_and_keyboard_shortcuts 

○​ Select bad channels + right click > Channels > Mark 
selected as bad (if needed) 

○​ Montage Selection: click Display configuration  > 
Montage > Subject01: SEEG  > Subject01 SEEG: (bipolar 2) 

■​ Select the montage for the dataset 
■​(Average, Referential, Transversal, or 

longitudinal) 
■​ For the SEEG dataset, select bipolar 2 montages for 

the continuous chain.  
○​ Filter settings for review are set under the Filter tab panel 

■​ ⚠ This is only for visualization ⚠  
■​ Select the checkbox to turn ON the high or 

low-frequency filter, and set any value.   
○​ Add annotations on the recording:  

■​ Got to record view > Events > Add Group >  Event A 
■​ Select 2 peaks and press E 
■​ Got to record view > Events > Add Group >  

Extended 
■​ Drag across the window, select peaks , Press E 
■​ Save annotation: File > Save modifications  
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9.​ Preprocessing  
 

Remove power line noise. 
o​ Compute Periodogram/Power spectrum density (PSD) 

▪​ Close all the figures 

▪​ Drag-and-drop (  ) raw file in Process 1, click [RUN] 

▪​ Add the process ( ): Frequency, Power spectrum density (Welch) 

▪​ Time window = All file, Window length = 5 s, Overlap = 50% 
▪​ Units = Physical 

▪​ Sensor types = SEEG 
▪​ Click Edit… and select MATLAB’s FFT defaults and click OK 
▪​ Click on Run 

o​ Review Periodogram 

▪​ Peaks at 60Hz, 120Hz, 180Hz on SEEG: Power lines 
(60Hz+harmonics) 

o​ Process Notch filter  
▪​ Select: Pre-process > Notch filter 

▪​ Sensor types = SEEG 

▪​ Frequencies to remove (Hz) = 60, 180, 300, 420, 540, 660, 780, 
900Hz 

▪​ Click on View filter response  
o​ Review Periodogram 

▪​ Troughs at 60Hz, 120Hz, 180Hz on: Power lines (60Hz+harmonics) 

Import recordings 

o​ Import in database 

▪​ Right-click on the pre-processed file > Import in database, and use 
the parameters: 

o​ Time window = 0 - 300.9995 s 

o​ Do NOT check Split in time blocks 

o​ Check Use events and select A 
o​ Epoch time = -2000 to 2000 ms 

o​ Check Remove DC offset, select All recordings 

■​ A new folder named A is created (no more raw indicator) 
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10.​ Import precomputed Brainstorm protocol 
📜 Prerequisite: If not yet done, please download the precomputed data from 
the following link: https://tinyurl.com/5n6hb6yz   

○​ Open Brainstorm 
○​ Click File > Load Protocol > Load from the zip file  

○​ Click on , and point to the downloaded zipped file:  
WorkshopSEEG_precomputed.zip 

○​ A protocol called WorkshopSEEG_precomputed should appear.  
○​ ⚠ If you double-click on the (  ) Link to raw and you get a warning 

message about a missing file, click Pick File… you need just to link to 
the correct EDF file: /Desktop/WorkshopSEEG_raw/Baseline.EDF 
 

11.​ Head Model Generation 
The forward models depend on the subject's anatomy, including head size and geometry, tissue conductivity, 
the computational method, and sensor characteristics. In the following sections, we will present the two 
approaches available in Brainstorm for constructing the head model for sEEG: the Boundary Element Method 
(BEM) and the Finite Element Method (FEM). However, only the BEM method is used in the subsequent 
sections. For more detailed documentation, please refer to the following link: 
https://neuroimage.usc.edu/brainstorm/Tutorials/HeadModel 

●​ Generate BEM head surfaces from the MRI:   

The BEM surfaces will be used for multiple purposes, including the display of head models, the computation 
of the forward solution using the BEM method, and the visualization of results. 

○​ Switch to anatomy view:   (1st button, on top of the database explorer)  
○​ Right-click on Subject01​

 > MRI segmentation > Generate head surfaces( )> OK 
○​ This will generate a surface file named ​

“head mask” estimated from the T1 MRI. 

○​ Right-click on Subject01 > MRI segmentation > Generate BEM surfaces( ) 

●​ Select Brainstorm 
●​ Number of vertices: Scalp = 1922, Outer skull = 1922  
●​ and Inner skull = 1922  
●​ Thickness of layers, Skull (mm)= 4 
●​ Click OK [This process will take ~2min] 
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○​ This will generate three surfaces (head, outer skull and inner skull) estimated from the“head 
mask”  and the “cortex” obtained from the segmentation. The BEM surfaces will be used for the 
BEM forward computation. 

○​ Set the default cortex to be used as the source space   
Double-click on mid_15002V to make it as the default cortex (in green), or right-click> set surface type> 
Cortex. If it's already green, there is no need to double-click. This will make sure to use this surface as 
the source space for the forward computation. 

●​ Display cortex ( ) and the other surfaces:   
○​ Double-click or right-click > Display 
○​ 3D figure: rotation, zoom, transparency 
○​ Predefined views and keyboard shortcuts: left, right, top, etc 
○​ Surface tab: smooth, sulci, edges 

●​ Close all figures (  button at top-right) 

●​ Atlases and Scouts (5 mins) 
●​ Display sources on the Cortical surface  

o​ Right-click on link ( ) > Cortical activations > Display on cortex  
o​ In the Scout tab, use the dropbox to select different Atlases  
o​ Display Desikan-Killiany and Destrieux 

▪​ Click on  
●​ Subdivided Desikan-Killiany 

o​ Atlas > Subdivide atlas> Area >  
▪​ Area of the sub-regions (cm2): 5 

o​ DON’T CLICK [OK] 

       Optional: Generate FEM head model (geometry):   
The FEM head model relies on the volume mesh (with tetrahedron) that can be 
either generated from the nested BEM surfaces (simplified FEM mesh) or from the 
MRI data, where a more realistic head model can be generated.   

●​ Generate FEM from BEM surfaces:   
○​ Press and hold “Ctrl” then select with the mouse the BEM surfaces 
○​ Right Click on the selected surfaces > Generate FEM Mesh​

> Iso2mesh > MergeMesh > Keep default values > OK 
■​ The Iso2Mesh plugin will be installed automatically > Agree  

📜 Read more about FEM mesh here: https://neuroimage.usc.edu/brainstorm/Tutorials/FemMesh. It is also 
possible to process the diffusion MRI (DWI) and generate conductivity tensors for the white matter.  
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12.​ Modeling interictal spikes using Min-Norm Imaging 
⚠ PLEASE DO NOT RUN ANY COMPUTATION IN THE FOLLOWING SECTIONS DURING THE WORKSHOP ⚠  

Most of the following steps require significant computation time.​
We will provide you with the precomputed files [output of the computation]. 

●​ Compute Forward Model (aka Head Model) (10 mins) 
○​ Compute the head model for SEEG using the OpenMEEG 

■​ Prerequisite: OpenMEEG plugin 
■​ Go back to the functional data view, navigate to the interictal_spike 

folder, and expand it 

■​ Right-click on the Nihon Kohden channel file ( )> Compute head 
model  

●​ Source space = Cortex surface,  
●​ Forward modeling methods = SEEG: OpenMEEG BEM, click OK 
●​ Use default BEM layers and conductivities. 
●​ Use default OpenMEEG options. ​

DON’T CLICK [OK] 
●​ Once completed, a new node  will appear on the database 

■​ Copy the head model files to the other folders.  
●​ Right-click on the head-model file ( OpenMEEG BEM | mid 15k)> Copy to other 

folders.📜  Since the other folders contain data collected from the same subject using 
the same set of electrodes, we do not need to re-compute the head model. 

○​ View Leadfield vectors  

■​ Right-click on head-model file ( ) > View SEEG lead field vectors  

■​ Select reference=MC2, click OK 

■​ Click on the figure and press E to display the electrodes 

■​ Make sure scouts are unselected 

●​ Go to the Scout tab, and make sure ALL and SEL are 
unselected 

●​ Go back to the Surface tab 

■​ Select Transparency = 90, and Press the Shift+Up arrow till the 
arrows are visible. 

■​ Press Up/down to change the Reference electrode, right/left to 
change the Target 

■​ Press  to close all figures 
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Optional: FEM Method with Duneuro 
The forward model can also be computed using the FEM method   

●​ The forward model can be calculated with the DUNEuro plugin 

●​ Compute Noise Covariance Matrix (for SEEG) (15 mins) 

●​ Explain Process section 
○​ Tabs Process1, Process2 
○​ File types:   recordings,   sources,  time-freq, and  

matrices 
●​ Switch to Baseline folder 

●​ Compute Link to raw file | copy ( ) for sEEG from Baseline recording 
○​ Select the trial group, right-click > Noise covariance > Compute from recordings: 

■​ Baseline = [0, 301] s 
■​ Select Block by block 
■​ DON’T CLICK [OK] 

■​ Copy the Noise Covariance ( ) to all the other folder 
●​ Right-click noise covariance file > Copy to other folders 

●​ Compute Inverse Model [Estimate the brain activity from the sEEG recordings](5 mins) 

●​ Switch to the interictal_spike folder,  

●​ Right-click on the head model (  ) > Compute sources, use 
these parameters: 

○​ Click on Show Details 
○​ Select Minimum norm imaging,  
○​ Select Measure: sLORETA [there are different methods] 
○​ Select Constrained: Normal to Cortex 
○​ Select Noise covariance regularization: Diagonal noise 

covariance  
○​ Sensors = SEEG 
○​ DON’T CLICK [OK] 

●​ Explanation of the inversion kernel (   ) and link ( ) files in 
the database  
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●​ Display sensor time series (5 mins) 

●​ Display time series 
○​ Right-click on Recording (  Spike (#1) …)> SEEG> 

Display time series  
○​ On the right side of the figure,  
○​ Select ( ) > Montage > Subject01: SPS >Subject01: SPS (bipolar 

2)  
○​ Select the first peak of SPS10-SPS11 (Time 0.041s)  

●​ Display the 2D Layout of the spike 
○​ Right-click on Recording ( )> SEEG> 2D Layout 

○​ Click  on the corner and select [-500, 500] 
 

●​ View Inverse Modeling results (10 mins) 

●​ Display on Cortex   
o​ Right-click on link (  sLORETA …) > Cortical activations > 

Display on cortex 
o​ Show sensors: 

▪​ Ctrl+L – SEEG contacts, Ctrl+E – for sensors 
o​ Show colormap Bar: Right Click on Colorbar > Colormap: 

Sources > Permanent menu 
▪​ Select Maximum: Global 
▪​ Contrast: -0, Brightness: 0 
▪​ Switch to Surface tab, Select Amplitude: 26% and Min 

size: 13 
●​ Display on 3D MRI Viewer 

o​ Right Click on link ( ) > Cortical activations > Display on MRI 3D 
o​ Show sensors: 

▪​ Ctrl+L – SEEG contacts, 
o​ Right Click and drag to select Axial, Coronal, and Sagittal slices  
o​ Press M to go to voxel with Maximum Intensity 

●​ Display on MRI viewer  
o​ Right Click on link ( ) > Cortical activations > Display 

on MRI (MRI Viewer) 
o​ Right Click on Colorbar > Electrodes > SEEG contacts 
o​ Show colormap Bar: Right Click on Colorbar > Colormap: 

Sources > Permanent menu 
o​ Set Amplitude: 56%, and press M to select the voxel with 

maximum intensity 
o​ Explain the Radiological and Neurological view 
o​ Explain MIP function and MIP anatomical 
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13.​ Modeling ictal wave using Min-Norm Imaging  
In this section same computation steps are performed as in 
the previous section.  

Compute Inverse Model 
●​ Navigate and expand  LVFA_and_wave 
●​ Display sensor time series (5 mins) 
●​ View inverse modeling results (2 mins) 
●​ Display on MRI viewer  

○​ Switch to Radiological 
○​ Right Click on Colorbar>Electrodes>SEEG contacts 
○​ Show colormap Bar: Right Click on Colorbar > Colormap: 

Sources > Permanent menu 
○​ Set Threshold=60%. Min size: 13 
○​ Set Maximum: Local  

 
​
​
 

14.​ Modeling ictal onset with LVFA using fingerprint analysis (Sensor Space)  
LVFA: Low Voltage Fast Activity  
Compute Bipolar Montage (5 mins) 

●​ Navigate and expand the LVFA_and_wave folder 
●​ Press  to close all figures 
●​ Drag-and-drop ( ) recording file in Process 1, click [RUN] 
●​ Add the process: Standardize>Apply Montage 

○​ Montage name: Subject01: SEEG (bipolar 2)[tmp]  
○​ Select Create new folders 
○​ DON’T CLICK [RUN] 

●​ A new folder with bipolar_2 suffix will appear 

          Compute Time-Frequency decomposition (5 mins) 
●​ Navigate and expand LVFA_and_wave_bipolar_2 folder 
●​ Delete any previous recordings in the Process 1 tab below 
●​ Drag-and-drop ( ) recording file in Process 1, click [RUN] 
●​ Add the process: Frequency>Time-Frequency (Morlet wavelets) 

○​ Sensor type: SEEG 
○​ Select Spectral flattening: Multiply output power values by frequency​

[📜 Normalizing/enhancing the detection of oscillatory components across frequencies] 
○​ Click Edit … to view and edit the parameters of the TF Morlet wavelets 
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■​ Frequency definition: Log (start:N:stop), 1:25:100 
■​ Central Frequency: 1 Hz, Time resolution (FWHM): 6s 
■​ Click [OK] 
■​ DON’T CLICK [RUN] 

View Time-frequency maps (10 mins) 
●​ Expand (  sEEG onset …) recording file, right-click on Power ( ), 

and select All channels 
●​ Click on Smooth display, Log(Power) 

○​ Give an overview off all the channels involved in the EZ patterns ​
[Pre-Ictal Spikes, Chirp -Narrow band of fast activity–, Suppression of slow pre-ictal 
frequencies] 

●​ Click on SPS8-SPS9 
○​ Check also PIN7-PIN8 

●​ Right-click on Colorbar>Colormap: 
Timefreq >Permanent menu 

●​ Set Turn-off [Absolute Value](if on), 
Maximum: Local, Contrast: 49, 
Brightness: -65 

●​ Demonstrate Left-click and Drag on the 
color bar to select the appropriate 
Brightness and Contrast  

●​ Right-click on the colored time-frequency 
plot > Power Spectrum, Time Series 

●​ Click to  close all figures 
 

📜 The sensor-level analysis identifies all electrodes that record epileptic activity with the associated fingerprint 
pattern. However, since this pattern can appear across multiple channels, accurately mapping it to its 
corresponding cortical region can be challenging. Therefore, analyzing it in source space may provide 
additional insights, allowing to examine the fingerprint at the level of cortical patches (rather than at the 
channel level).  ​
In the two previous sections, the analysis relies on two key concepts: Minimum Norm (MinNorm) imaging for 
source reconstruction and time-frequency (TF) analysis in sensor space.​
In the next section, we will evaluate the fingerprint analysis in the source space.  
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15.​ Modeling ictal onset with LVFA using fingerprint analysis (Source Space) 
Change folder 

o​ Switch to folder LVFA_and_wave 

Compute Source model 
o​ Same as in previous sections [all the steps are already completed] 

Extract Scout time series 
●​ Drag-and-drop link ( ) in Process 1, click [RUN]  
●​ Add the process: Extract>Scout time series  

○​ Select Desikan-Killiany [187] 
○​ Select Scout function: PCA 
○​ DON’T CLICK [RUN] 

Compute Time-Frequency decomposition 
o​ Drag-and-drop ( ) matrix file in Process 1, click [RUN] 
o​ The rest of the steps are the same as in previous sections  

Display on Cortex 

o​ Right-click on link ( ) > Cortical activations > Display on cortex 

o​ Select the Scout tab 

▪​ Select  atlas, click  

▪​ Select Scout: postcentral R.2 

View Time-frequency maps 
o​ Expand (  sEEG onset …) recording file, right-click on Power ( ), and select All channels 
o​ Click on Smooth display, Log(Power)  
o​ Click on postcentral R.2 
o​ Right-click on Colorbar>Colormap: Timefreq 

>Permanent menu 
o​ Set Maximum: Local, Contrast: 52, 

Brightness: -63 
o​ Right-click on the colored time-frequency plot 

> Power Spectrum, Time Series 
o​ Click to  close all figures 

 
 
 
 
 
Demonstrate Left-click and Drag on the color bar to select the appropriate Brightness and Contrast 
https://neuroimage.usc.edu/brainstorm/Tutorials/Colormaps  
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16.​ OPTIONAL: Modeling ictal onset with repetitive spiking (Sensor and Source Space) 
Compute Bipolar Montage 

o​ Navigate and expand ictal_repetitive_spike folder 

o​ Close all the figures 

o​ Drag-and-drop ( ) recording file in Process 1, click [RUN] 
o​ Add the process: Standardize>Apply Montage 

▪​ Montage name: Subject01 SEEG (bipolar 2)[tmp]  
▪​ Create a new folder 

o​ DON’T CLICK [RUN] 
o​ A new folder with bipolar_2 suffix will appear 

 

Display time-series 

o​ Navigate to the folder with bipolar_2 suffix 
o​ Right-click on Recording, SEEG>Display time-series 
o​ Change Montage to PIN > PIN (orig) 

 
 

Compute Time-Frequency decomposition 

o​ Same as in previous sections, only for the sensor PIN5-PIN6 
 

View Time-frequency maps 

o​ Expand (  sEEG onset …) recording file, RrRight click 
on Power( ) , and select One channels 

o​ Click on Log(Power) 
o​ Click on PIN5-PIN6 
o​ Right-click on colorbar>Colormap: Timefreq 

>Permanent menu 
o​ Set Maximum: Custom [-18.5, -8], Contrast: 23, 

Brightness: -60  

Computing inverse models 
○​ Change back to the ictal_repetitive_spike folder 
○​ Same as in previous sections 

View inverse modeling results 
○​ Display time-series 

■​ Right-click on Recording, SEEG>Display time-series 
■​ Change Montage to PIN(orig) 
■​ Set Frequency filter 

●​ High-pass: 5 Hz 
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●​ Low-pass: 55 Hz 
○​ Display sources on MRI viewer  

■​ Right-click on link ( ) > Cortical activations > Display on MRI (MRI Viewer) 

■​ Right-click on Colorbar>Electrodes>SEEG contacts 

■​ Show colormap Bar: Right Click on Colorbar > Colormap: Source > Permanent Menu 

■​ Maximum: [0, 2]  
■​ Click on the Surface tab, set Amplitude: 33%  
■​ Explain MIP's functional and MIP anatomical 
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17.​ OPTIONAL: Post-surgical anatomical data processing and resection delineation 
 

BrainSuite's module auto_resection_labeling can coregister pre- and post- surgery MRI's of subjects that 
underwent surgical resection. The module coregisters pre- and post- surgery MRI images and identifies 
resection as a volumetric mask. This volumetric mask can be imported as a MRI parcellation (aka MRI atlas) in 
the subject space and then used to generate volume scouts in the source space. The method takes into 
account linear and nonlinear deformations occurring due to the resection surgery. The resection mask is 
identified in both pre-op MRI and post-op MRI coordinates. The resection mask in pre-surgery MRI space 
could be useful for identifying SEEG electrodes within the resection or to identify anatomy that has 
been resected. The resection mask in post-surgery MRI space could be useful as a registration mask. 

Please refer to the github page and Brainstorm documentation for more details on the process.  

In the section below, we will just be importing a BrainSuite precomputed resection mask into Brainstorm and 
visualize it. 

​ ​
​ 📜 Precomputed sample for the steps below  is also available in WorkshopSEEG_precomputed.zip 

●​ Method-1: Resection mask identification in pre-surgery MRI space 

○​ New subject:  Subject02 

○​ Import T1 pre-surgery MRI 
■​ Right-click on Subject02 > Import MRI 

■​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 

■​ Select file: 
/Desktop/WorkshopSEEG_raw/Resection/preop_raw.nii.gz 

■​ In the MRI Viewer, click on compute MNI normalization and select the maff8 algorithm.  
■​ Click Save & Close 

○​ Import T1 post-surgery MRI 

■​ Right-click on Subject02 > Import MRI 

■​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 

■​ Select file: /Desktop/WorkshopSEEG_raw/Resection/postop_raw.nii.gz 
○​ Brainstorm asks about registering the new T1 with the reference T1 

image 
■​ Select the option: SPM [if not installed, Brainstorm will download 

and install SPM as plugin] 
■​ Reslice the volume: Yes 

○​ Import processed resection mask in pre-surgery MRI space 

■​ Right-click on Subject02 > Import MRI 

■​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 
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■​ Select file: /Desktop/WorkshopSEEG_raw/Resection/resection_mask_preop_space.nii.gz 

■​ Select Ignore for coregistration and No for reslicing 
●​ Coregistration cannot be performed on the resection mask  
●​ The resection is already in the pre-surgery MRI space 

■​ Display resection on the post-surgery MRI 
●​ Right-click on postop_raw_spm_reslice > Set as default MRI 
●​ Right-click on resection_mask_preop_space > Display > Display on default MRI 

○​ Optional (for visualization): Create a 3d volume  for the resection mask 
■​ Right-click on resection_mask_preop_space > MRI 

segmentation > Generate head surface 
●​ Number of vertices: 10000 
●​ Erode factor: 0 
●​ Fill holes: 0 

■​ Click OK. 
■​ Rename the generated surface head mask to 

resection_preop_space. 
■​ Display resection volume on the post-surgery MRI 

●​ Double-click resection_preop_space to open the volume 
in the 3D viewer 

●​ Surface tab > Color button (choose something that is not 
gray for better visualization of the resection) 

●​ Surface tab > Add a surface > Anatomy 
 

📜 Precomputed sample for the steps below  is also available in WorkshopSEEG_precomputed.zip 
●​ Method-2: Resection mask identification in post-surgery MRI space 

○​ New subject:  Subject03 
○​ Import T1 post-surgery MRI 

■​ Right-click on Subject03 > Import MRI 

■​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 

■​ Select file: 
/Desktop/WorkshopSEEG_raw/Resection/postop_raw.nii.gz 

■​ In the MRI Viewer, click on compute MNI normalization and select 
the maff8 algorithm.  

■​ Click Save & Close 

○​ Import T1 pre-surgery MRI 

■​ Right-click on Subject03 > Import MRI 

■​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 
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■​ Select file: /Desktop/WorkshopSEEG_raw/Resection/preop_raw.nii.gz 
○​ Brainstorm asks about registering the new T1 with the reference T1 image 

■​ Select the option: SPM [if not installed, Brainstorm will download and install SPM as plugin] 
■​ Reslice the volume: Yes 

○​ Import processed resection mask in post-surgery MRI space 

■​ Right-click on Subject03 > Import MRI 

■​ Select format: MRI: NIfTI (*.nii, *.nii.gz) 

■​ Select file: /Desktop/WorkshopSEEG_raw/Resection/resection_mask_postop_space.nii.gz 

■​ Select Ignore for coregistration and No for reslicing(the resection is already in the pre-surgery 
MRI space) 

■​ Display resection on the post-surgery MRI: Right-click on resection_mask_postop_space > 
Display > Display on default MRI 

○​ Optional (for visualization): Create a 3d volume  for the resection 
mask 

■​ Right-click on resection_mask_postop_space > MRI 
segmentation > Generate head surface 

●​ Number of vertices: 10000 
●​ Erode factor: 0 
●​ Fill holes: 0 

■​ Click OK. 
■​ Rename the generated surface head mask to 

resection_postop_space. 
■​ Display resection volume on the post-surgery MRI 

●​ Double-click resection_postop_space to open the volume 
in the 3D viewer 

●​ Surface tab > Color button (choose something that is not 
gray for better visualization of the resection) 

●​ Surface tab > Add a surface > Anatomy 
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