3D reconstruction not properly oriented orthogonal slices

Dear Francois,

recently I tried to reconstruct an iEEG implantation in one of our patients, when something odd happened.
I encountered that the 3D reconstruction does not occur to be properly oriented orthogonal slices (see screenshot below).


Have you ever come across something like this? The same data and anat folders and files appear correctly displayed on another machine. Hence, I thought this might be an issue of my GPU. However, the right device is selected in matlab and should therefore be in use for the display.


ans =
CUDADevice with properties:

                  Name: 'GeForce GTX 1060 6GB'
                 Index: 1
     ComputeCapability: '6.1'
        SupportsDouble: 1
         DriverVersion: 9.1000
        ToolkitVersion: 8
    MaxThreadsPerBlock: 1024
      MaxShmemPerBlock: 49152
    MaxThreadBlockSize: [1024 1024 64]
           MaxGridSize: [2.1475e+09 65535 65535]
             SIMDWidth: 32
           TotalMemory: 6.4425e+09
       AvailableMemory: 5.2676e+09
   MultiprocessorCount: 10
          ClockRateKHz: 1759000
           ComputeMode: 'Default'
  GPUOverlapsTransfers: 1
KernelExecutionTimeout: 1
      CanMapHostMemory: 1
       DeviceSupported: 1
        DeviceSelected: 1

However, could this be in issue of the plugin used to reconstruct the orthogonal image in brainstorm/matlab? I could not figure out what plugin brainstorm uses to produce the 3D images. Can I adapt or manually update it?

I am looking forward to your answer.


Yes, I've seen problems like this before.
This is due to issues with your OpenGL drivers. You device might not support some OpenGL directives.

However, this is not related with your CUDA GPU (which is a computing device), but with the device used for rendering the OpenGL figures.

>> opengl('info')
                          Version: '4.6.0 NVIDIA 461.09'
                           Vendor: 'NVIDIA Corporation'
                         Renderer: 'GeForce GTX 960M/PCIe/SSE2'
            RendererDriverVersion: ''
        RendererDriverReleaseDate: '31-Dec-2020'
                   MaxTextureSize: 16384
                           Visual: 'Visual 0x07, (RGBA 32 bits (8 8 8 8), Z depth 16 bits, Hardware acceleration, Double buffer, Antialias 8 samples)'
                         Software: 'false'
             HardwareSupportLevel: 'full'
        SupportsGraphicsSmoothing: 1
    SupportsDepthPeelTransparency: 1
       SupportsAlignVertexCenters: 1
                       Extensions: {358×1 cell}
               MaxFrameBufferSize: 16384

I think I remember you should have a supported version of OpenGL >= 3.2 in order not to have any graphical problem with Matlab.

In any case, this is not an issue related with Brainstorm, but with Matlab.
If you can't fix the problem, you can disable the OpenGL rendering in the Brainstorm preferences, or open a bug report on the MathWorks website.