A bug when computing head models

Dear Sir/Madam,

I am using Brainstorm to perform some EEG source analysis. However, when I want to compute head models for the default anatomy (ICBM152), it always appear the following error message.
image

I have tried to reinstall Brainstorm, and installing OpenMEEG alone following the instruction from the website, but it doesn't resolve the issues.

Does that mean I could not compute head models for default ICBM152 template? Look forward to your reply, and thank you very much for providing this nice software to all of us for EEG analysis.

Best regards,
Eden

Do not try to install OpenMEEG independently from Brainstorm: Brainstorm uses it own version anyway.

  • Delete any manually installed version of OpenMEEG.
  • Delete the openmeeg folder in the brainstorm user folder: $HOME/.brainstorm/openmeeg
  • Restart the computation, just to make sure openmeeg is correctly downloaded and installed.

If you still get the same error:

  • delete again $HOME/.brainstorm/openmeeg
  • From Brainstorm, menu: Update > Update OpenMEEG > Download
  • Download the first version for Linux from the OpenMEEG website
  • Install it in Brainstorm with the menu: Update > Update OpenMEEG > Install
  • If you get the same error, repeat with the next version. If you get a different error message, please copy-paste the full error message here (from the Matlab command window).

If you can't make this work:

  • Please copy-paste here the output of the ver command in Matlab.
  • We'll need help from the OpenMEEG developers: @Alexandre @mclerc @sik

Hi Francois,

Thank you very much for your prompt reply. I have tried to install 2.4.0 to 2.4.2 version, and all versions produce the same results. I am wondering is it possible to be a read/write permission issue? i.e. Brainstorm could not access the file because of reading restriction. I have tried to use terminal to enable permission but still could not fix the problem. My matlab ver output is the following:

MATLAB Version: 9.9.0.1467703 (R2020b)
MATLAB License Number: 40821746
Operating System: Linux 4.15.0-128-generic #131~16.04.1-Ubuntu SMP Wed Dec 9 17:33:47 UTC 2020 x86_64
Java Version: Java 1.8.0_202-b08 with Oracle Corporation Java HotSpot(TM) 64-Bit Server VM mixed mode

MATLAB Version 9.9 (R2020b)
Simulink Version 10.2 (R2020b)
Bioinformatics Toolbox Version 4.15 (R2020b)
Computational Anatomy Toolbox Version 1739 (CAT12.7)
EEGLAB Toolbox to process EEG data Version - see
MATLAB Compiler Version 8.1 (R2020b)
MATLAB Compiler SDK Version 6.9 (R2020b)
Parallel Computing Toolbox Version 7.3 (R2020b)
RICOH MEG Reader toolbox for MATLAB Version 1.0.3
Signal Processing Toolbox Version 8.5 (R2020b)
Statistical Parametric Mapping Version 7487 (SPM12)
Statistics and Machine Learning Toolbox Version 12.0 (R2020b)
Symbolic Math Toolbox Version 8.6 (R2020b)
Text Analytics Toolbox Version 1.6 (R2020b)
Yokogawa MEG Reader toolbox for MATLAB Version 1.5.2

Look forward to your reply. And thanks again for your kind help.

Best regards,
Eden

We'll need input from the OpenMEEG developers.
@Alexandre @mclerc @sik @papadop

You could also try to open an issue on the OpenMEEG github:
https://github.com/openmeeg/openmeeg/issues

Can you locate the file om_assemble and issue the command:

ldd om_assemble

There should be a line saying:
libOpenMEEG.so.1 => Not found

What is the content of the line libOpenMEEGMaths.so.1 => ?

Normally, these libraries are provided with the package and you should find them not very far from the place where you found om_assemble (presumably in the same folder if I remember well). Do you have them ? If yes check their permissions...

If you do not know where to look for om_assemble try:
locate om_assemble (I do not know by heart where BrainStorm places OpenMEEG).