Can not convert DWI to DTI

Dear Francois,

After importing the T1 file and finishing the MNI norm I cannot convert the DWI file to DTI.
I am using the template files provided by BrainSuite, also I used my own MRI files but I keep running in the same error message.

I am working with Matlab 2019b, MATLAB Runtime 2019b for Windows and Brainsuite: v.21a.

Please see the image attached.

Thank you in advance for your guidance!

Kind regards,

Could you try and put your data in path without spaces:


@Anand_Joshi ? any idea

Possibly non-ascii characters or spaces in the path are causing the problem - my guess is the former..
Moving folder to a simpler path without these (C:\ for example) would solve the problem. Ideally BDP should take care of these, but would be good to confirm if that is the reason.

Dear All,

Thanks for the prompt reply.
I changed the path but still does not work.

May you have other ideas?


Have you tried running BDP from command line directly? I suspect something in your Matlab environment might be interfering with BDP.

Dear Anand,

I did not.
Can you explain to me in a few steps how should it be done?

Thank you!

Hi Adam,

There is probably some functions in your matlab path that have same names as the BrainSuite functions. You can reset your matlab, or try to use a terminal.

To do so, you need to download this preprocessed data from this link :

and then unzip the folder, and open a terminal within this folder, then try to run this:

bdp.exe 2523412.bfc.nii.gz --tensor --nii 2523412.dwi.nii.gz --t1-mask bse_smooth_brain.mask.nii.gz -g 2523412.dwi.bvec -b 2523412.dwi.bval

or if it fails :

bdp.exe 2523412.bfc.nii.gz --tensor --nii 2523412.dwi.nii.gz -g 2523412.dwi.bvec -b 2523412.dwi.bval

Please share a screenshot of the final output.



The problem is that I wanna apply it to my own data.
Honestly, I don't understand, how should I proceed, I am not familiar with MATLAB that much but many thanks for the effort and help.



You will apply it to your data, we want to understand why you are getting the errors.
Once we solved it you can apply it to your data.

Dear tmedani!

Sorry for the delay.

I got the same error message with PowerShell.

Any ideas?


Hi @Adam

Thank you for checking that.

It seems that you are getting a similar error as in matlab. It seems that there is something wrong with Brainsuite installation.

Which version of Brainsuite do you have?

Could you share the DTI files? I will try to run it (share a private google drive folder or send it by email?).

@Anand_Joshi, any idea?