CAT12: Error Creating Link - Access is Denied

Greetings Francois,

I am trying to run CAT12 on the default ICBM152 template over a windows-based virtual machine. Trying to do so leads to the following error:


I am going to create a report of the issues I am running into while using this VM, and was wondering if you could expand on this error/how it can be resolved? It is simply a permissions issue related to my account?

Thank you,

The error message "Access is denied" is returned by Windows when Brainstorm tries using the command "mklink /D" to create a link from the SPM12 toolbox folder $HOME/.brainstorm/plugins/spm12/spm12/toolbox/cat12 to the CAT12 installation folder $HOME/.brainstorm/plugins/cat12/cat12.

This is most likely a problem of access rights of your user.
Access rights issues on Windows 7 or 10 are sometimes difficult to identify and fix...

  • Try running Matlab as administrator
  • Check the access rights of all the subfolders of the .brainstorm folder
  • Make sure your user has the rights to create symbolic links

If you can't figure out a solution:

  • Uninstall the CAT12 and SPM12 plugin from Brainstorm,
  • Download and install them manually on your computer (not in any of the Brainstorm folders), with CAT12 really located in the SPM12 toolbox folder,
  • Configure Brainstorm to use these custom installations for the two plugins, with the menu "Custom install":

Thank you Francois! I tried the Workaround method, and it worked.