CAT12 segmentation error: No executable modules


When running brainstorm and attempting to perform T1 MRI segmentation with CAT12 to obtain cortex surfaces, I receive the following error:

Error: Line 472:  spm_jobman>fill_run_job
** No executable modules, but still unresolved dependencies or incomplete module inputs.
** Call stack:
** >spm_jobman.m>fill_run_job at 472
** >spm_jobman.m at 247
** >process_segment_cat12.m>Compute at 359
** >process_segment_cat12.m>ComputeInteractive at 442
** >process_segment_cat12.m at 28
** >bst_call.m at 28
** >tree_callbacks.m>@(h,ev)bst_call(@process_segment_cat12,'ComputeInteractive',iSubject,iAnatomy) at 3085

I'm not sure how to resolve this error so any advice is appreciated, thank you. Both Brainstorm and CAT12/SPM are up to date.

By itself, this error is difficult to interpret.
Please copy-paste the full text output you get between the moment you start the CAT12 computation and the error.

Both Brainstorm and CAT12/SPM are up to date.

Please specify if both CAT12 and SPM12 were installed as Brainstorm plugins, or if you installed them manually on your computer.


Hello Francois,

Thank you for the response but I have resolved the issue by unloading SPM. I believe I had two versions separate versions installed on different paths and that is what was causing the difficulties.

Hi! I had the same error than you. Could you tell me how to solve it? Thank you so much!

In this particular case, I was able to solve the issue by unloading the plug ins and reloading them after restarting brainstorm. Hope this helps.


I've tried this, but it doesn't seem to work.

Here's what I get:

BST> Plugin spm12 already loaded: C:\Program Files\SPM\spm12
BST> Adding plugin cat12 to path: C:\Users\marco\.brainstorm\plugins\cat12\cat12
BST> Executing callback LoadedFcn: LinkCatSpm(2);
BST> Creating symbolic link: mklink /D "C:\Program Files\SPM\spm12\toolbox\cat12" "C:\Users\marco\.brainstorm\plugins\cat12"
BST> SPM12 template found: C:\Program Files\SPM\spm12\tpm\TPM.nii
BST> Checking latest online version for cat12...
BST> Processing dependencies: cat12 requires: spm12 
BST> Plugin cat12 already loaded: C:\Users\marco\.brainstorm\plugins\cat12
BST> Emptying temporary directory...

SPM12: spm_cat12 (vCAT12.8.2)                      01:03:34 - 13/03/2023

   _______  ___  _______    
  |  ____/ / _ \ \_   _/   
  | |___  / /_\ \  | |     Computational Anatomy Toolbox
  |____/ /_/   \_\ |_|     CAT12.8.2 -

 CAT default file:

Item tools: No field(s) named
Item tools: No field(s) named
Your version of CAT12 is up-to-date.

** Error: Line 472:  spm_jobman>fill_run_job (line 472)
** No executable modules, but still unresolved dependencies or incomplete module inputs.
** Call stack:
** >spm_jobman.m>fill_run_job at 472
** >spm_jobman.m at 247
** >process_segment_cat12.m>Compute at 361
** >process_segment_cat12.m>ComputeInteractive at 444
** >process_segment_cat12.m at 28
** >bst_call.m at 28
** >tree_callbacks.m>@(h,ev)bst_call(@process_segment_cat12,'ComputeInteractive',iSubject,iAnatomy) at 3089

Your help would be much appreciated!


The problem seems to be CAT not being identified as a SPM toolbox.

Maybe unload and reload SPM and CAT plugins?
If it doesn't work uninstall and reinstall them both.

Check your Matlab path to make sure that you don't have SPM installed anywhere else on your computer.
Execute which cat12 and which spm12 in your Matlab command window: they should both be in the $HOME/.brainstorm/plugins folder.
Try starting spm12, close it. Then start cat12, close it. Can you start both?

Thanks for your suggestions, François.
I went through all of them but couldn't work around this issue.
Guess I'll just go the freesurfer way.


If you can install and start spm12 and cat12 manually, not as Brainstorm plugins but as it is recommended in the respective websites, you could:

  1. Run CAT12 independently from Brainstorm and later import the output in Brainstorm with the menu "Import anatomy folder", just like with FreeSurfer but changing the file format to import.
  2. If it works, tell Brainstorm to use your manually installed versions:

Dear François,

Thanks to your suggestions it's finally working!
I downloaded CAT straight from its website and saved it into SPM toolboxes folder.
Then I chose custom install and selected the folder in Brainstorm.

Many thanks for your advice!

There is CAT12 segmentation error i have attached the ss

@Tanmay I moved your message here as it possibly the same error.

i tried unloading and reloading both the plugins but on reloading the cat12 i am getting this error

This is also addressed on this forum:

Thanks Francois!
It worked.