Custom head model - DBA Tutorial used

Hello, I am following the DBA tutorial: Compute sources in deep cerebral structures using my own research. I got to the point of the source estimation heading and reached a hang-up: the tutorial instructs to compute a head model and select the custom head model option, however this option is unavailable for me. Is this because I am using EEG rather than MEG?

Thank you!

If the option "Custom source model" is not available, it is because your default cortex file does not contain an atlas "Source model".
Make sure you followed carefully all the steps of the tutorial and that the correct cortex surface ("mixed") is selected as your default.

@Francois
I deleted previous files and followed the tutorial steps again to the same result. The option did become available however, once I closed the figure window (for cortex_mixed) and tried to compute the head model again. I am wondering why this is. In addition, once I closed and reopened the figure for cortex_mixed, the scouts changed labels from [dba|constr] back to [Mean]. Will this affect my results?

Update: Selecting the "Structures" heading gives the [Mean], while "Source Model" still shows [dba|constr]
Still unsure why I needed to close that window to have the option available but it works. Thank you for the helpful tutorial.

Because in cases, the modifications are saved to the database only when you close the figures.

In addition, once I closed and reopened the figure for cortex_mixed, the scouts changed labels from [dba|constr] back to [Mean].

You are not looking at the "source model". Maybe this is the "structures" atlas that is selected. Same region names, but not the same function.

@Francois

I have the head model sorted out, however I am unable to compute the sources in the manner given by the tutorial. I am given the standard source computation options rather than the wMNE option displayed in the tutorial. Is this because I am using EEG rather than MEG or is this an independent issue?
My window is shown left in the figure below while the tutorial is shown right.
Different%20options

You are using an oudated version of Brainstorm.
Start by updating Brainstorm if you expect to follow the online tutorials.

@Francois
It updated last night and I told it to update twice just now but it is still showing the different window. Could it be that the tutorial shows a previous version?

Ooops... Indeed, the tutorial shows the old option window.
We'll fix this soon.
Thanks for reporting!

1 Like

@Francois
Thank you!
I the meantime, should we use Current density map, dSPM, or sLORETA to remain consistent with the tutorial?

wMNE in the old version corresponds to Minimum norm imaging + Current density map.

1 Like

Tutorial screen captures fixed:
https://neuroimage.usc.edu/brainstorm/Tutorials/DeepAtlas#Source_estimation
Thanks