Error 134 during headmodel computation

Hello,

I have an error numbered 134 when running a headmodel computation.

** Error: OpenMEEG call: om_minverser
** "/home/bic/jhan24/.brainstorm/tmp/openmeeg_hm.mat"
** "/home/bic/jhan24/.brainstorm/tmp/openmeeg_hminv.mat"
** OpenMEEG error #134:
** ./om_minverser version 2.4.0 compiled at Jun 21 2018 08:39:47 using OpenMP
** Executing using 4 threads.
**
** | ------ ./om_minverser
** | /home/bic/jhan24/.brainstorm/tmp/openmeeg_hm.mat
** | /home/bic/jhan24/.brainstorm/tmp/openmeeg_hminv.mat
** | -----------------------
** terminate called after throwing an instance of 'OpenMEEG::maths::MatioError'
** what(): Exception: InflateSkip: inflate returned buffer error
** /bin/bash: line 1: 19573 Aborted ./om_minverser "/home/bic/jhan24/.brainstorm/tmp/openmeeg_hm.mat" "/home/bic/jhan24/.brainstorm/tmp/openmeeg_hminv.mat" 2>&1
**
** Many OpenMEEG crashes are due to a lack of memory.
** Reduce the number of vertices on each BEM layer and try again.

Here is a dropbox link containing my data and the OpenMEEG tmp folder.
https://www.dropbox.com/sh/qi707vtkklsv9ly/AADV0i4zODuh4CSLtvA9uPl4a?dl=0

Thank you,
Claire

Hello,

I was wondering if you had a chance to look at my data.

Thanks,
Claire

@Alexandre Any update?

Hi,

I just tried this on your data:

om_assemble -hm openmeeg.geom openmeeg.cond hm.mat
om_minverser hm.mat hm_inv.mat
om_assemble -dsm openmeeg.geom openmeeg.cond openmeeg_dipoles.txt dsm.mat

It does not produce any crash for me (on a mac). So I don’t know what is happening.

what OS are you using?

We will try to replicate on the same system as yours.

Alex

This is not a terminal, dude :slight_smile:

message was sent too fast… I edited now :slight_smile:

I’m so cheeky now and would give my answer here as a software developer to the error. ^^

In your error message you can see the Exception: InflateSkip: inflate returned buffer error was ejected.
You can read more about this here: (https://zlib.net/zlib_faq.html#faq05)

In addition I could see in the error message, which was not the newest compiler version of OpenMEEG used.
Maybe that is a reason too.

@Alexandre would it be better to install the latest OpenMEEG version form http://openmeeg.gforge.inria.fr/download/
that is the version 2.4.0 compiled at Jul 13 2018 16:05:27

and futher more i saw on GitHub the entry (https://github.com/openmeeg/openmeeg/issues/70).
where the are sugesting that you should not have beyond 10’000 Vertixes in Total. (you have 10’000*3)
So i would suggest degresing the vertices on the head mask and inner and outer skulls. Since these can trigger the inflate buffer error in my opinion if they are too big.

1 Like

Thanks for the suggestion. I am not using Mac but it’s running on Ubuntu.

I will reduce the number of vertices and retry. What I find puzzling however is that the head model computation ran for all other participants (that have similar/same number of vertices). I would appreciate any insight.

Claire

For the subject that did not work, I tried it on my personal mac and it worked…

Thanks,
Claire