Error BST> Loading current protocol

Dear BST team,

BST worked well until this morning, I got an error while starting to launch BST

I tried to delete brainstorm and then dowload it again but it didn't resolve my problem.

I use Matlab R2021a on Windows 10 and the brainstorm version is : 17-Oct-2023

You can see below the error I get


BST> Starting Brainstorm:
BST> =================================
BST> Version: 17-Oct-2023
BST> Compiling main interface files...
BST> Deleting old process reports...
BST> Loading configuration file...
BST> Checking internet connectivity... ok
BST> Initializing user interface...
BST> Starting OpenGL engine... hardware
BST> Reading process folder...
BST> Loading current protocol...
Error using regexprep
All cells must be char row vectors.

Error in gui_brainstorm (line 34)

Error in bst_startup (line 626)
gui_brainstorm('SetCurrentProtocol', GlobalData.DataBase.iProtocol);

Error in brainstorm (line 123)
bst_startup(BrainstormHomeDir, 1, BrainstormDbDir);

Thank you in advance for your help,

Hi @VincentDornier

Have you installed other Matlab toolboxes?

If so, can you remove the latest changes on your Matlab path and try again?


Thank you for your reply !

Yes I have installed other Matlab tooloboxes (fieldtrip for example), I remove all the changes on my matlab path but I still have the same error .


We cannot replicate such error in our side.

  • Did posted the entire error message?

  • Check which regexprep is being used. In the Matlab Command Window:
    which('regexprep', 'all')
    it should only be the built-in function, something similar to:
    built-in (MATLABROOT/toolbox/matlab/strfun/regexprep)