Error importing/reviewing raw MEG .fif files

Hello,
Our group is running into the attached errors when attempting to import/review an empty room .fif recording file. This happens after updating to the most recent version via the update function in the interface. Older versions <2020_02_08 do not have the same issue. On a related note, is there a single location to pull older releases of the software?
Thanks!command_line_error gui_error

This could be related with recent updates of the MNE-matlab library.
Can you please share an example file?
=> Upload it somewhere and post the download link here.

Hi Francois,
Here's an example file: https://www.dropbox.com/s/3s5c8q3ris1fp9l/emptyroom_01_tsss.fif?dl=0
Nick

Thanks for the example file.
This is indeed due to the use of a syntax that makes the parser if older versions of Matlab crash.

If fixed it in Brainstorm (to download it: menu Update > Update Brainstorm):

I also reported it on the MNE-matlab repository: https://github.com/mne-tools/mne-matlab/pull/22

Perfect, thanks for quickly addressing this!
Is there an archive of older releases?

From Github, you can all the files corresponding to any commit, and therefore get the version of Brainstorm at any point in time. Google for help if you need.

Hi Francois,

After I updated my brainstorm, I had problem importing .fif file. It was an error with RESAHPE function
Untitled

I tried to use an older version (under my C:\user\Documents. Wasn't able to update there so I installed the new version in my D:\ drive) that was able to import the file. Curious enough, it had the same error. My MATLAB version is 2018b. The only other related thing I could think of is that I uninstalled MATLAB 2017a today because I haven't been using it...

Any suggestion could be helpful. Thanks!

I just re-downloaded the .fif file from our data drive. It worked this time. Not sure what's the problem with the previous data. It didn't seem to have been modified.