Errors in coregistration between MRI and FEM models created by SimNIBS 4

Dear brainstorm team,
After importing the MRI from .nii file, I set up the subject's NAS, LPA, RPA, etc. via MNI normalization. After that I ran SimNIBS4 (4.0.1) directly for FEM model creation and everything was more than ready to run. However, the FEM model I got does not fit the subject's MRI. But the head mask I got from SPM does not have this problem. Below is the screenshot of the comparison between the surface of the scalp I extracted from the SimNIBS FEM model and the MRI.

There is nothing wrong with the structure of the FEM model itself it just looks like there is a problem with the registration between model and the MRI. Do you have any suggestions on how I can solve this problem? Thank you in advance.

Best regards,

Hi Christopher,

Did you check if the center of RAS and your FE head model is aligned?
I've only used SIMNIBS version 3.x.x (can't recall the exact version), but the center of RAS coordinate was not (0,0,0) while the FE model generated by SIMNIBS was corrected to (0,0,0).

Are you using linux to run simnibs? If so, following command will give you the information on the central point of RAS coordinate (fsl and freesurfer needed):
mri_info --cras

You can simply subtract them from the coordinates of the vertices of FE model that is generated, and it will be aligned to MRI data.
Hope this helps.



Dear Jimin,
Thanks a lot for your valuable advice. So I went back to the MRI part to check coordination parameters. And I find that it may be an issue due to the rotating angle of voxel space and world space being too large. I solved this problem by resampling the images at the suggestion of my colleagues working on brain MRI, which allowed MR to be harmonized in terms of voxel and world space parameters.
Thank you very much for the thoughts you have provided.

Best regards,