Flat Time - series components

Hello everyone,
I have an issue regarding the display of the component time series when running an ICA.
In detail, I have some resting data acquired with an EEG High-Density, that I pre-processed (removing bad channels, bad epochs, filtering and downsampling). When I open the data, signal is displayed correctly, with my selected amplitude (0.1 mV). When I run the ICA, the process works fine, and I am also able to properly display components topography.
Instead, when I display component time series, all 50 components appear flat, and on the upper right corner my data appears to be calculated in "No units", either as NaN or -Infinite.
Due to this and the fact that the components topography are well displayed, I think it is a matter of visualization. I have tried serval modifications to either the ICA pipeline or to visualization settings (amplitude, display mode, and so on), but nothing seems to work.
Do you have any suggestion on how to solve this issue?
I am running Brainstorm on the latest version.
Thanks in advance for any suggestion

Hi,

The No units legend is shown as the component time series, aka activations, have arbitrary units. Still you should see a numeric value.

image

The scalp maps have also arbitrary units. The fact that shown the same units as the data is a minor bug.

The signals resulting from mixing activations and scalp maps are the ones that have the same units as the data.

@stefanovicentin If you still have this problem, we'd need some additional information to debug it further.

  • Could you please share an example dataset (original file format)? Upload it somewhere are post a download link here.
  • Describe step by step how to reproduce this error in Brainstorm from this file.

Thanks

@stefanovicentin We changed the way the display of the units is handled for the various figures showing SSP/ICA time series or topographies. Now it should always show "a.u." (arbitrary units).
Please update Brainstorm to get this fix.

Dear Francois, thank you very much! Now it is more clear. I managed to solve the issue by changing the RAM on the computer, that was not able to successfully show me the components. Thanks again for the support!