Problem to simulate signal from scouts

Hi all

I'm working for long with head models in Brainstorm, normally i was using models with 15000 vertex in the cortex, however i had the "bad" idea to improve the number of vertex in the cortex to 60000. But i'm having problems, how i don't have eeg real, i'm using the tab process1 for simulate eeg. how?:


i select some scouts on the cortex and after

run/simulate generic signal (i'm using sinusoidal signals)/ simulate recording from scout.

So finally i can get my eeg signal.

I have done this for several models with 15000, however now i have generated new head model with the same input than before (MRIs), i only have improved the number in the cortex to 60000, but when i tried to run the simulation, the eeg doesn't appear.

EEG generated with my model with 60000 vertex in the cortex

EEG generated with my model with 15000 vertex in the cortex

Plssss.. help, really i don't understand why i can't generate eeg in my model with 60000 vertex in the cortex, with the same procedure used for my models with 15000 vertex in the cortex..


Adding information

I have been investigated about this error, and finally i found that OpenMEEG is having problems to generate the LeadField with 60000 vertex. The OpenMEEG complement is doing a empty matrix (with 0 ), instead to generate the correct Lead Field. For this reason when i want to generate my data, with process simulation from scouts give me only zeros. The procedure i'm using is correct, and moreover the OpenMEEG complement is finishing the process of lead matrix generation successfully, but truly is generating a bad Gain Matrix. How can i fix it?

An example of the matrices generated by OPENMEEG module for 60000 vertex in cortex... (is the only parameter which i have changed from my other models which do work.

I have attached a image with part of the matrix generated by OPEMEEG

Cheers i hope you can help me


If OpenMEEG doesn’t crash and returns a gain matrix, it’s not a memory issue.
If you only have a few very strong values and zeros everywhere, it could be due to some anatomical singularities that are not handled well by OpenMEEG.

You can try to increase the resolution of the BEM meshes you are using to generate your model (>2000 vertices per layer).
Or use a spherical head model…

I’ll transfer your message to the OpenMEEG developers, in case they have anything to add.


it seems indeed like a numerical issue with your headmodel. Do you have dipoles really close to the inner skull? Do you have flat triangles in the BEM meshes?

What version of OpenMEEG are you using?


In Brainstorm:

I have been working with 5 different MRIs different ages
and in everyone of them i had the same error.

Previously i worked with the same MRIs but with 15000 vertex, and i got a good and functional Lead Field.
Now i downloaded again Brainstorm and i actualized this, moreover i downloaded the version of OPENMEEG which you sent me.

Also i improved the number of my external layers maintaining the ratio between cortex/layers = 7.8 approximately so, i’m using 35000/4322 and processing the dipoles by 4000 blocks . In my other computer i’m already running another process with 60000 vertex in cortex 7682 per layer using adjoint formulation and adaptative integration.

i will tell you about my results and if i finally i can obtain a big matrix with OPENMEEG


Can you try if it work well with a spherical model?
(to make sure the problem is not on the Brainstorm side)


I’ve finished all the different models that i wanted, and moreover i’ve generated the model that you said me, and all is ok with brainstorm. The final problem is from the complement of OpenMEEG, i couldn’t work with the model with 60000 vertex on the cortex, and really i don’t know the reason. Finally i needed to diminish the number of vertex to 50000, and to work with “Process dipoles by blocks 4000”, which is really slow, but at least is useful…


Maybe because of some memory issues…
Good that you find a working solution!

FYI: To address all the recent questions we had related with simulations, I added some code in Brainstorm and wrote a new tutorial: