You do not have the right to write in this folder

Hi everyone,

I'm getting an error when I try to open a protocol I worked on previously.

"You do not have the right to write in this folder. (lists folder). Opening protocol in read-only mode"

I've tried uninstalling and re-installing, moving folders around, checking on permissions etc, but seem to be stuck. I'm using my personal university laptop and stumped. Any suggestions would be incredible.

Thank you!


Brian Kavanaugh, PsyD, ABPP
Board Certified Pediatric Neuropsychologist, E. P. Bradley Hospital
Assistant Professor, Warren Alpert Medical School of Brown University


Can it be that the user name has change since then? Or that the Protocol was created when you logged as different user?

Open Brainstorm, try to create a new Protocol, and open it.
If it does not work, check the Attributes of your brainstorm_db folder

Hi Raymundo,

Thanks for getting back so quickly!

No to different user name or different user.

But it is weird, I can always create a new protocol, but when I exit that protocol and then try to re-enter, it gives me the read-only error.

I checked attributes and it is the following here, which is the same as my other folders.

I also made sure the folder was added to the matlab path in case that was the issue.

Should the brainstorm_db be in a certain place?


Thanks Raymundo!


That is not an issue, and I would not do it.
What does it happen if you uncheck Read-only attribute in the folder?

When I uncheck and try to open a protocol again, I get the same issue. When I go back to attributes, it is again checked as the black box (default).

Are you using Brainstorm with or without Matlab?
Which Windows version?

with matlab. windows 10.

i just tried to run it in our remote desktop/ood option, and it worked fine. not sure what i'm doing on my personal laptop to mess it up, but i do not get the error when using the remote desktop.

Remote access to the personal laptop, or remote desktop to another computer?

Can you run Matlab as admin in your personal laptop?

sorry, remote access to a university virtual environment unrelated to my personal laptop. which seems to work great.

yes, i ran matlab as admin in my personal laptop and still get the same issue.

i'm sorry! i can just go with the virtual environment if I can't solve the read-only issue