Brainstorm does not "see" Brainsuite

Dear all,

I am experiencing an issue while trying to conduct DTI within Brainstorm using Brainsuite (on OSX). I have installed Brainsuite, and when I try to perform "Convert DWI to DTI", and that I provide my .nii, .bvec and .bval, I have an error message from Brainstorm that Brainsuite is not installed, and to fill the access path within the preferences, which I did.

I have tried to install Brainsuite elsewhere, and to change it accordingly in the Preferences panel in Brainstorm, nothing helps... One of my colleagues just tried on Windows and it worked, so I suspect this is OS-related...

Thanks in advance for your feedback, and thanks from this fantastic tool that is Brainstorm !

All the best,

Julien

Hello @Julio

Did you try to start Brainsuite software on your computer?
is it working?

@Anand_Joshi

I have tested this on Linux and Windows, but not MacOS, maybe this reacts in a different way than Linux... This might require some debugging.

The process starts by adding the BrainSuite directories to the system path, and then Brainstorm relies on having the executables bdp, bfc and bse available on the system path.

Can you try adding the BrainSuite folders (subfolders bin and bdp) manually to the system path?

getenv('PATH')
setenv('PATH', [getenv('PATH'), ':', BsBinDir, ':', BsBdpDir])
getenv('PATH')

Another solution to test would be to open a terminal, add the BrainSuite folders (subfolders bin and bdp) to the system path - Google for help with this, and then start Matlab/Brainstorm.

1 Like

@Julio What is the path that you entered?

@tmedani : yes, it works :wink:
@Francois : many thanks for your suggestions, will try asap what you suggested and let you know !
@ajoshi : the path is basically: /Users/julien/Applications/Brainsuite

1 Like

@Julio
If you type
/Users/julien/Applications/Brainsuite/bin/BrainSuite

at the command line, does BrainSuite open? The path looks odd to me. It should be BrainSuite instead of Brainsuite, I think capitalization matters in Mac.

Sorry to bother you. I have a question about the eig-dti.In brainstorm,The normal operation is importing dwi.nii.gz, *.bvec (orientation of the gradient) and *.bval (value of the gradient) to got eig-DTI.
We obtained DTI (diffusion tensor imaging) directly during the MRI scan, which also contains three files (dti.nii.gz, *.bvec and *.bval). We want to use the same steps to import directly in brainstorm the file gets eig-DTI. We did use the same operation, and we did get such data(eig-DTI). Our current problem is that we found that brainsuite also uses (dwi.nii.gz, *.bvec and *.bval)to calculate dti tensor(which may be the eig-DTI in brainstorm). We don’t know whether our approach that import (dti.nii.gz, *.bvec and *.bval) to use (convert dwi to dti) to got eig-dti in brainstorm is correct.Do I have to use dwi data to calculate eig-dti in brainstorm? Is the eig-dti obtained by directly importing dti data correct? We don't know whether brainsuite can directly import (dti.nii.gz, *.bvec and *.bval) to get eig-dti.

@ajoshi @tmedani ?

1 Like

Hi @caofuzhi

I believe that you mean DWI instead of DTI, there is maybe confusion in the terminology between DWI and DTI.

https://www.ncbi.nlm.nih.gov/pmc/articles/PMC2967146/

The DTI is computed from the raw data DWI and can't be obtained directly from the MRI,
therefore I believe that you have the DWI, and it's what you need to use in Brainstorm.

I think you have already tested it and you got the expected results (from your emails).