Doesn't work brainstorm3.bat (username with special chars)

I tried to install "" with "Matlab Runtime: R2022b (9.13)" on Windows10 PC by "brainstorm3.bat", but it occured the following Error.

... Matlab M-code Stack Trace ...
com.mathworks.toolbox.javabuilder.MWException: An error occurred while initializing the component.
fl:filesystem:InvalidArgument: The file or directory is not a reparse point
        at com.mathworks.toolbox.javabuilder.internal.MWMCR.mclInitializeComponentInstance(Native Method)
        at com.mathworks.toolbox.javabuilder.internal.MWMCR.access$700(
        at com.mathworks.toolbox.javabuilder.internal.MWMCR$6.mclInitializeComponentInstance(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at com.mathworks.toolbox.javabuilder.internal.MWMCR$2.invoke(
        at com.sun.proxy.$Proxy0.mclInitializeComponentInstance(Unknown Source)
        at com.mathworks.toolbox.javabuilder.internal.MWMCR.newInstance(
        at bst_javabuilder_2022b.Bst_javabuilder_2022bMCRFactory.newInstance(
        at bst_javabuilder_2022b.Bst_javabuilder_2022bMCRFactory.newInstance(
        at bst_javabuilder_2022b.Run.<init>(
        at org.brainstorm.RunCompiled.main(

Should I do to solustion this error and to correctly work "brainstorm3.bat"?

thank you.

HI @keroria,

Can you provide the entire text that is shown in the terminal when you double-click on brainstorm3.bat?


1 Like

Hi, @Raymundo.Cassani

Thank you for your reply.
I attached the capture of the terminal.

Best regard

The issue seems to be related to the path where the Brainstorm folder is.

  • Does your path (C:\fukukawa\Brainstorm\...) have any special character?
  • Could you unzip the brainstorm zip file on to your Desktop folder and try to run it from there?


Thank u your quickly reply.

The Answers of your questions are following.

Q1: Does your path (C:\fukukawa\Brainstorm\... ) have any special character?
A1: Maybe No. That folder's path is

Q2: Could you unzip the brainstorm zip file on to your Desktop folder and try to run it from there?
A2: I tried, but it was same fail result.
Actualy, I'm Japanese so I use Win10 of Japanese version, and then looks like my desktop folder has special charactors of Japanese...
Thae path of my desktop folder is
"C:\Users*福川幸代*\OneDrive -*γƒ‡γ‚Ήγ‚―γƒˆγƒƒγƒ—*\brainstorm_230507_bin\brainstorm3\bin\R2022b"

The first try was on the folder of "C:\fukukawa\Brainstorm\brainstorm3\bin\R2022b"(it has no special character), so I don't think that the reason was special charactors.
Any other possible causes?

Best regards

Thank you for the detailed information!
I was able to replicate brathe problem and find a fix:

Create a new Windows user without special characters, and run the brainstorm3.bat when logged with that new user

While the path for your brainstorm installation (C:\fukukawa\Brainstorm\brainstorm3\bin\R2022b) does not contain special characters.[Brainstorm will create the User directory (.brainstorm) in the Windows User folder ("C:\Users\username\.brainstorm ") which in this case contains special characters.

Hi, @Raymundo.Cassani

Thank you for your advice!

I can installed and open brrainstorm!

thank you!