OpenMEEG error#126 and source estimation group analysis

Hi there,

I am receiving the following error when attempting to run OpenMEEG

** Error: OpenMEEG call: om_assemble -HM
** “/home/jbel877/.brainstorm/tmp/openmeeg.geom”
** “/home/jbel877/.brainstorm/tmp/openmeeg.cond”
** “/home/jbel877/.brainstorm/tmp/openmeeg_hm.mat”
** OpenMEEG error #126:
** /bin/bash: ./om_assemble: cannot execute binary file
**
** Many OpenMEEG crashes are due to a lack of memory.
** Reduce the number of vertices on each BEM layer and try again.

I am connected to a server from a Mac OS X and I have also tried updating brainstorm and installing earlier versions of OpenMEEG, as has been advised in prior discussions with similar issues.

Also, I am attempting to compute source averages by group (i.e. resting state EEG data for 19 young individuals) using 3-Shell sphere model for now, but no file is created under "group analysis" folder for sources, thus I cannot compute a group average whereby I can view the average power distribution by frequency band.

I am using the MEG resting state & OMEGA database (CTF) tutorial as my guide

Any help would be much appreciated

kind regards

@jbel877

./om_assemble: cannot execute binary file

suggest a problem of rights on the file. Can you check if the files are executable
in the Unix sense?

Alex

sorry what do you mean by Unix sense?

is you do:

ls -l om_assemble

output should start with:

-rwxr-xr-x

x means you can execute the file.

is -I om_assemble
Undefined function or variable ‘is’.

Did you mean:

isa -I om_assemble

ans =

 0

this is what I got when I typed “is -I om_assemble” into the terminal

it did some autocorrection… It should be:

ls -I om_assemble

but you need to type this in the mac terminal not in matlab.

That doesn’t seem to be working either …

[jbel877@fmhsappprd01 ~]$ ls -l om_assemble
ls: cannot access om_assemble: No such file or directory
[jbel877@fmhsappprd01 ~]$

you need to go where the file om_assemble is stored by brainstorm.

@Francois I think we really need you here …

Alex

I think I have been using the wrong binary file, so I have tried again using the linux binary file (as the server is run through a linux) but receive a new error message which I have attached. I have tried to install the missing library libstdc++6 using the command ‘sudo apt-get install libstdc++6’ in the terminal but lack the permissions to install it.

Is my issue likely to be due to not having the necessary library to install OpenMEEG? Picture1

what OS and version are you using?

there is a number of issues on the web related to this error. See for example:

sorry. it's hard for me to help more.

Alex

No worries, thank you for your help

Sorry for the late reply.

@jbel877: For your group analysis, you will always estimate the sources separately for each subject, then project the results on the template, and finally average them.
https://neuroimage.usc.edu/brainstorm/Tutorials/CoregisterSubjects

@Alexandre: Is there anything I need to fix regarding this error?

1 Like

I started documenting a workaround for the GLIBCXX error here:
https://neuroimage.usc.edu/brainstorm/Tutorials/TutBem#Errors

1 Like