Standardize channels removing one extra channel?

Hey Team,

I am trying to run ft_timelock statistics for a set of 10 subjects. However, I encountered a mismatch in the number of channels in the data collected across subjects. Specifically, for 2 subjects, the ground was FPz, while for the others, it was AFz.

Initially, I tried re-adding the AFz using a montage (Regarding Reference channel - #3 by Francois), filling in the space, and then standardizing the test. However, the remaining channels were 62 instead of the expected 63.

To address this, I changed my approach by marking the altered ground AFz as bad, ensuring a consistent number of channels (63) and the same channel names across all subjects. As a proof of concept, I tried running the time-locked statistics between 2 subjects with a total of 60 files, but I encountered an error.

Please advise on what should be done.

please find image of the error attached

As the error indicate, you must have the same list of channels in all the files to be processed.
Do as suggested, run the process Standardize > Uniform list of channels with all your files in the process tab, since you probably do not want to run test on the Ground electrode, select the option Keep only the common channel names. Now you can use the resulting files for the ft_timelock_statistics

Everytime i ran that. i was losing a channel which is important for me.

Anyway, I figured the issue, there was a mismiatch in my channel files, so i changed the chanel file and applied a montage which was general for all the other subjects.

thank you Raymundo!