Surface not aligned to T1 after importing to BST

Hi there,

I have T1 and cortical surface generated by Freesurfer. They are aligned when viewing in freeview. However, after I import the T1 and then the surface, they are not aligned anymore. I did not define the fiducials and did not apply the transformation while importing the T1, I also did not apply the transformation while importing the surface. This is considering the fact that they are already registered. Could you please help? I can send the T1 and surface files by email. Thanks a lot.


Hi @zhengchen
Thanks for reporting this issue.

Can you try importing the free-surfer anatomy folder instead of importing the files individually?

Hi @tmedani, thanks for your suggestion. I know if I import the whole freesurfer anatomy folder it will work. However, this is a bypass solution in my case, since the surface and T1 are processed in a pipeline where freesurfer is just part of the process (I will need to find the freesurfer folder somewhere, as the final results are rearranged in different folders). I would like to only import the T1 and the surface into BST. It is a bit weird that they are not aligned after importing to BST. Maybe there are some mistakes I made in the pipeline. Thanks a lot.

There is probably some information missing when importing only these two files.

Can you check this

you may need to accept the transformation when you are importing the data.

Hi @tmedani , thanks a lot for your suggestions. Let me explore a bit and will get back to you.


1 Like

Hi @tmedani, I finally could import the surface which is aligned to the T1. However, this is still a bypass solution for me and I guess BST may have an issue/bug with reading gifti surface file (at least the gifit I have), or maybe I did not get the correct process of importing gifti in BST.

Here is the process that gives me an aligned surface: import T1 by accepting the transformation >> import surface file (converted to freesurfer surface format) by accepting the transformation. The trick is that I have to convert the gifti file to freesurfer surface format using mris_convert shown here as save the surface as freesurfer surface format in freeview. If I import the gifti file directly, after trying all possible combinations of accepting or not the transformation for T1 or surface, the surface can not be aligned.

It is also related to the surface format drop-down options while importing the gifti. If the file type is selected as All surface files ".*", it LR coordinates are sort of mirrored. If GifTI/World coordinates (*.gii) is selected, LR is fine but the surface is not aligned

In case it is specific to my files not in general to gifti, please find the T1 and surface (gifti and freesurfer format) here. Ideally, I may not need this extra step to convert gifti first into freesurfer format before importing it to BST, but I don't know the right process to do so.

As I understand, the ACPC alignment in BST is mainly for visualization. If I export the imported surface from BST to a file, should I expect that the coordinates are the same as the original surface file? It is the case for T1 according to my experience.

Thanks a lot.