Cannot add new SEEG Electrode

I loaded MRI, post-SEEG CT, and co-registered them, created the mesh. When I tried to add new SEEG electrodes manually, it gave me this error (picture). sometimes I can do it, sometimes I cannot. But this time, it has not worked even restart Brainstorm and computer multiple times...
Thanks for your time.


Hi @wzhang ,

Thank you for reaching out to us.

Can you tell me which version of Brainstorm you are using ?

I would also suggest you look at this tutorial below which is very similar to the workflow you are trying to do:

Thanks for answering my question! I updated the version of Brainstorm to Apr 19, and the problem is fixed now.
Also I found that sometimes it is challenging to separate the first 2 contacts just adjusting the window/level of CT. It will be wonderful if we can manually send the coordinates instead of finding center of the contacts automatically.
Again, thanks for keeping advancing the software and the training!

Thank you for your valuable feedback. We have noted this requirement and will work on adding features to better localize/edit contacts in 3D in such cases. For now if you are not able to separate out the contacts one way to do it is follow this tutorial where you can add the contacts manually (using the MRI viewer),